[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: recent udev upgrade failure on alpha


I had some time today to try again an upgrade of my AlphaStation 500 to
"linux-image-2.6.38-2-alpha-generic". I got again an error on loading the
xfs.ko module from initrd  (I typed it manually from the boot screen to this
mail *g*):

Module xfs: Relocation (type4) overflow vs _xfs_buf_find
FATAL: Error inserting xfs (/lib/modules/2.6.38-2-alpha-generic/.../xfs.ko):
Invalid module format

All other modules before (like SCSI QLA1040 and SATA SiI3114, Tulip
Ethernet,... load successfully). The last kernel that works is (as written
below): 2.6.31-1-alpha-generic, all after 2.6.32 fail with the same error
message (with some minor differences).

I had to go back to the working kernel and of course prevent upgrading

Has anybody any idea what's wrong with the XFS module? My root file system
on a SATA disk (not /boot) is XFS. Maybe its again a binutils bug.


> -----Original Message-----
> From: Uwe Schindler [mailto:uwe@thetaphi.de]
> Sent: Thursday, February 24, 2011 7:53 PM
> To: 'Matt Turner'
> Cc: 'Bob Tracy'; debian-alpha@lists.debian.org; mcree@orcon.net.nz
> Subject: RE: recent udev upgrade failure on alpha
> From: Matt Turner [mailto:mattst88@gmail.com]
> > On Thu, Feb 24, 2011 at 10:09 AM, Uwe Schindler <uwe@thetaphi.de>
> > wrote:
> > > My bigger problem is that recent kernels (even the stable one no
> > > longer work for me). On mounting my root  xfs filesystem it produces
> > > a message about a wrong relocation format / some other linking
> > > problem when loading the XFS .ko (the exact message is not known,
> > > its somewhere in the screen buffer of the already rebooted with
> > > older kernel machine, I can only remember what the problem was -
> > > next time I try I will take a pen and write down the message on
> > > console). This happens with the last stable kernel version, did not
> > > test
> > > 2.7.37-1 until now.
> > > The last kernel that works for me is 2.6.31-1-alpha-generic. Does
> > > anybody knows what the problem loading the XFS module is?
> > >
> > > Unstable is else still running fine!
> >
> > This is the first I've heard of XFS not working (though, I've never
> > used
> it
> > myself). Have you reported this anywhere?
> >
> > Please mail linux-alpha@vger.kernel.org and the appropriate XFS
> > mailing
> list
> > to try to get this fixed.
> This mail thread is already going to these mailing lists (linux-
> alpha@vger.kernel.org).
> I will try 2.6.27-1-alpha-generic ASAP and report if it is maybe solved,
else I
> will post the exact error message XFS kernel module is presenting (at
> it's not a problem of my installation, because 2.6.31 and previous works
> with XFS since years on an 128 Gig disk). Is the UDEV problem gone with
> 2.6.37 kernel, too? I think it's 2.6.33 that fixed it (from your previous
mail on
> this thread).
> Finally I still have to tell that Debian Unstable is still running very
well with this
> AlphaStation 500 with EV56! So I never understood why there was no Debian
> release for Alpha anymore :(
> Uwe
> --
> To UNSUBSCRIBE, email to debian-alpha-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact
> Archive:
> http://lists.debian.org/008101cbd454$02036770$060a3650$@thetaphi.de

Reply to: