[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Radeon 7500 and radeonfb driver

Somewhat related to the subject, I wanted to report I finally tried
enabling DRI for the 7500 (having been bitten by it several times), and 
it works great.  I'm getting a frame rate of approx. 460 fps with
glxgears.  Please don't be distracted by these comments, because the
subject has nothing to do with X11 :-).  I just wanted to acknowledge
the successful efforts of the Xorg side of the house.

As for the subject, about the only outstanding issue I'm seeing has to
do with the boot logo.  If I boot, say, 2.6.21-rc1 with the following

vmlinux.gz ro root=/dev/sda3 video=radeonfb

things works as expected, and I get the nice "DEC" penguin logo in the
upper left corner of the screen.  However, if I specify a supported but
non-default resolution such as in the following boot line:

vmlinux.gz ro root=/dev/sda3 video=radeonfb:1024x768-16@70

then the screen clears, the mode switches, new text after the mode
switch starts at the middle line of the screen, and the boot logo never
appears.  Everything works correctly otherwise, i.e., once the bottom
half of the screen fills with boottime messages, the text scrolls
upward as new lines are written, eventually filling the entire screen.

This behavior has existed and been consistent for all 2.6 kernels I've
tried since buying the 7500.  It's an irritant, but hardly a show-stopper.
I just want things to work the way they do on my x86 box with the vesafb
driver :-).

Bob Tracy                   WTO + WIPO = DMCA? http://www.anti-dmca.org

Reply to: