[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: "Failed to Fork Child Process"

I am running "testing". How would I go about implementing or testing the fix? Or is there any way to easily verify that this is the same problem that I am facing? Also, whe I look under system monitor processes, I see hundreds of "gnome-cups-icon" zombies. Is that the culprit? Any suggestions on how to fix, and make the system useable again?

I have the following :
getconf GNU_LIBTHREAD_VERSION    returns:  linuxthreads-0.10
gcc --version returns: gcc 4.1.2 20060901 (prerelease) (Debian 4.1.1-13)


Tom Evans wrote:

Are you running "stable"?

There is still an outstanding issue with the libc/libpthreads in "testing" and "unstable" whereby threads are not properly reaped after termination. This causes processes to leak and eventually no more threads or processes can be created.


There appears to be an upstream fix, according to an entry in the bug, but I have not yet tried it:

*From:* "Uwe Schindler" <uwe@thetaphi.de>
*To:* <325600@bugs.debian.org>
*Subject:* Seems to be fixed by NPTL
*Date:* Sun, 8 Oct 2006 22:11:28 +0200

Tested today the latest experimental libc6.1 (package version 2.3.999 but
inside is glibc 2.4) and locales package - no more defunct processes!

Uwe Schindler
H.-H.-Meier-Allee 63, D-28213 Bremen
eMail: uwe@thetaphi.de


Robert Oram wrote:

I have 2 LX164's, and have been running the latest version of Etch on both for months now. I run several different configurations on each machine, for testing purposes. While most issues have gone away with newer releases, one has remained persistent. The machines boot normally, and seem to run normally for 10 to 40 minutes, but then begin to produce the same error, no matter what I try to do.

Error: Could no launch menu item
Details:  Failed to fork child process
(Resource temporarily unavailable)

This persists until I cycle the power, as it will not allow me to do a reboot. Any ideas as to the cause or how to fix it? What can I do to troubleshoot?


Reply to: