[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RES: State of XOrg in testing/unstable

Steve Langasek wrote:
> It's possible that xserver-xorg-video-all isn't installable yet on alpha;
> there have been some build failures in individual drivers, which may prevent
> having a consistent set of all of them at present.
> Anyway, I've tested 7.1 on my system too, and it doesn't look any better
> (with the MGA driver) than 7.0 did.  So I'm beginning to dig through the
> diff for the driver between 6.9 and 7.1, and if I don't find anything, start
> looking at the server as well.

I resolved the xserver-xorg-core installation issue by --force-conflicts
installing it, then removing all the xserver-xorg-video-XXX packages (had
to force ignoring dependencies when removing the xserver-xorg-video-all
package), reinstalling xserver-xorg (which was the package preventing
removal of xserver-xorg-video-all, and it wouldn't configure because of
a missing virtual package supplied by any one of the video drivers),
reinstalling xserver-xorg-core, installing the desired xserver-xorg-video-XXX
packages (NOT including the -all package this time), then configuring the
xserver-xorg package.  "apt-get check" is now happy, so I guess I am too :-).

Tried the Xorg ati driver this evening with a 2.6.18 kernel.  Machine
was booted/running in normal console mode (no framebuffer).  Kernel
configuration parameters for the radeon driver are:

# CONFIG_FB_RADEON_I2C is not set

Typed "startx" from a console virtual terminal.  Screen went blank,
disk drive chattered as all the normal GNOME stuff fired up.  Nothing
on the display, so decided to try logging in remotely to see if the
machine was still responsive.  Retrieved a copy of the Xorg.0.log file,
and verified that all the X-related stuff was running.  Decided to get
brave and tried switching the console to a virtual tty, and at that point,
the machine hung solid -- keyboard unresponsive (unable to toggle numlock
and capslock LEDs), and unable to login remotely.  Hit the reset switch
and looked for something in the logs, but nothing was written between the
time the X server started and I had to forcibly reboot the machine.

Tomorrow I'll try yanking the ATI card and putting the old TGA2 back in,
just to see if Xorg 7.1 will work with the hardware that worked back in
the 6.8 days.

Bob Tracy                   WTO + WIPO = DMCA? http://www.anti-dmca.org

Reply to: