[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Why no /dev/hda even though the disk is recognized?

I don't have the exact log any more, but partman showed a small free
partition at the beginning (where "/" should have been),
a partition corresponding to the swap partition (but
not identified as such), and a large free partition afterwards
corresponding to the entire rest of the disk.

partman in no way reflected the disklabel I had created,
which was essentially this:
7 partitions:
#       start       end      size     fstype   [fsize bsize   cpg]
  a:     4096   1052672   1048577       ext2                      
  b:  1052672   5148672   4096001       swap                      
  d:  5148672  15388672  10240001       ext2                      
  e: 15388672  21532672   6144001       ext2                      
  f: 21532672  22581248   1048577       ext2                      
  g: 22581248  117231407  94650160       ext2                      

> > I was able to use the debian-installer to shell-out and 
> execute fdisk
> > to create a BSD disklabel and useful partitions.  The 
> shell, however,
> > does not have a /dev/hda even though it has a /dev/discs/disc0/ and
> > /dev/ide/host0/bus0/target0/lun0/ which point to the IDE drive.
> > Using "discover scsi" finds it's controller, but using
> > "discover ide" shows nothing.
> > partman sees the drive, but of course that's useless.
> Er, "useless" how?
> If partman sees the drive, it should also be able to see the 
> partitions
> (since this is all done through the kernel /dev tree, as exposed by
> devfs).  If it can see the partitions, it should be able to configure
> appropriate mount points for the installer.  Where does the 
> uselessness
> ensue?
> -- 
> Steve Langasek

I have started over, using the above partitions, with a 2.2.22 SMP
image off a woody distribution and that works fine, except the eepro100
driver keeps getting transmit timeouts.  I upgraded most things to sarge.

I then tried a 2.4 image, but it never recognized my IDE drive.
So I tried a 2.6.6-1 SMP image and it correctly recognized my IDE drive,
but the system is not stable and the network driver (eepro100 or e100)
is also just as unstable (timeouts).  That's, of course, a separate issue
from the partition/drive recognition problem.


Attachment: smime.p7s
Description: S/MIME cryptographic signature

Reply to: