[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: gcc too old for cxx ?

Helge Kreutzmann wrote:

> Hello !
> I tried to install the recent made "wrapper" debs for the compaq
> compilers. I got the rpms & the deps, installed ccc, updated cpml
> (which was already present) and finally wanted to install cxx.
> Unfortunately I get:
> Error: Unable to find GCC at /usr/lib/gcc-lib/alpha-linux/2.95.4. GCC
> must be in stalled.

Right.  I forgot to version the gcc dependency in the cxx installer package.  I
need to update ccc to use and depend on 2.95.4 too, will probably do that later

> I "only" have /usr/lib/gcc-lib/alpha-linux/2.95.3
> I have a partially woody system so I updated gcc (was already latest
> version) and gcc-2.95 (got a new binutils as well). Nevertheless I am
> still on 2.95.3.

Yes, 2.95.4 is in unstable, where cxx is...

> Is it save to simply symlink 2.95.4 to 2.95.3 or else where do I get a
> newer gcc from ?

You can get it from unstable, or else look in /var/lib/dpkg/info/cxx.postinst
which has:

/usr/lib/compaq/cxx- \
  cxx- /usr/lib/gcc-lib/alpha-linux/2.95.4

Just run that script again with 2.95.3 and it should work.  You should also run
the rest of the commands in the postinst- or just edit the postinst and rerun
that whole script.


-Adam P.

GPG fingerprint: D54D 1AEE B11C CE9B A02B  C5DD 526F 01E8 564E E4B6

              Welcome to the best software in the world today cafe!

Reply to: