[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: bugs: dynamic libraries, xconsole, xdm

On 21 Feb 2001, ian wrote:

> some bugs I've encountered while upgrading to glibc-2.2.1 and
> xfree86-4.0.2:
> xfig_3.2.3.c-4
> This binary is dynamically linked to a library called 'libXaw3d.so.7',
> which as far as I can tell exists nowhere; it's not in the xaw3dg
> package from stable, testing, or unstable. I don't know how this could
> happen; however, after making a symlink from libXaw3d.so.7 to
> libXaw3d.so.6 and running ldconfig, it appears to work OK.

I'll check this out.  It should be linked against libXaw.so.7 instead.

> The library libc-2.2.1.so does not contain the symbol lstat, but does
> define the symbols __lxstat and __lxstat64, as suggested by the header
> file.  I'm not sure exactly what's going on here, but clearly
> something is wrong. It looks like it might be related to the large
> file (>4GB) support in glibc-2.2.

xfig may need a recompile.  I'll try to test this tonight to find out.

> xconsole (from xbase-clients_4.0.2-1)
> I found that this program was consuming 80% of the CPU time on a
> 275MHz PC64. This can't be right. xdm_4.0.2-1 runs this program by
> default; I had to disable it (/etc/X11/xdm/Xsetup).

Ugh.  This may be harder to debug mostly because of the prohibitive
size of Xfree86 to compile.  I'll play with this on the UP2k at work
one day to see what I can find.

> xdm_4.0.2-1
> Finally, xdm itself takes about five minutes to start up, again on a
> 275MHz PC64. This is independent of the xconsole problem mentioned
> above. I know that the problem is not with the X-server, because
> startx brings it up much faster.  Something must be wrong; the xdm log
> file is no help, because it's just a condensed version of the X-server
> log. There doesn't appear to be any xdm-specific information in it;
> perhaps this is a clue.

That's very odd.  xdm starts right up on my SX and even faster on my
UP2k at work.  Granted, I haven't tried it out since 4.0.2-1, but it
worked very well then.  Initial load time may be killing you, though.
Is xdm being started at boot time or is this from the command line
after boot?

> I hope this information is helpful to somebody.

Me too :-)


Reply to: