[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Second NIC on Alpha XLT-300

On Tue 20 Feb 2001, Donald Spoon wrote:
> I recently came into possession of an old DEC Alpha XLT-300.

Hey, that's my primary alpha! Don't call it old :-)

> The first added NIC I tried had a Realtek 8139 chipset.  The

These aren't really to be recommended anyway, from what I hear
the realtek nics aren't that good.

> The second additional NIC I tried was a Lynksys LNE100TX
> that purports to have a DEC "tulip" chipset, or derivitive.
> I had a bit more success here in that it works and sets up
> OK, BUT a "ping" from the Alpha machine brings up an error
> message indicating a bad CRC checksum and consistantly
> identifies byte 42 as being the "mangled" one.  Needless to

What version ping do you use?  I recently fixed something
similar in a ping in unstable.  However, on potato, the ping
from netbase 3.18-4 should work (works for me :-)

> say I get a 100% packet loss.  Strangely, if I ping the

Well, if you're getting errors in the received packets,
you don't actually have packet loss, but packet corruption...

> Alpha from another machine, it appears to respond correctly.

This would be consistent with a buggy ping program.

> Again I have tried various kernel configs and am currently
> using the latest "tulip" modules from Donald Becker's site.
> I do NOT get the hard freeze when using this NIC.

Are both the on-board and the Lynksys recognized by the same
instance of the driver? I.e., loading one module gives you
two interfaces? That's what should happen if it's a tulip-compatible;
that's what I have in my multia that works as firewall:

: eth0: DE434/5 at 0x8800 (PCI bus 0, device 8), h/w address 08:00:2b:e4:d6:a6,
:       and requires IRQ10 (provided by PCI BIOS).
: de4x5.c:V0.544 1999/5/8 davies@maniac.ultranet.com
: eth1: DC21041 at 0x9000 (PCI bus 0, device 12), h/w address 00:00:c5:5d:91:b4,
:       and requires IRQ15 (provided by PCI BIOS).
: de4x5.c:V0.544 1999/5/8 davies@maniac.ultranet.com
: eth1: media is TP.
: eth0: media is EXT SIA.

> My first thought was that this was something wrong in the
> "tulip" NIC module, but considering the fact that the
> "built-in" NIC works fine using the same module, I suspect
> it is something else.  Considering the regularity of the
> location of the bad byte in the "ping" response, and the

Did you confirm that ping works fine with the on-board?

Otherwise, I believe the 3Com cards should work fine on alpha...

Paul Slootman
home:       paul@wurtel.net      http://www.wurtel.demon.nl/
work:       paul@murphy.nl       http://www.murphy.nl/
debian:     paul@debian.org      http://www.debian.org/
isdn4linux: paul@isdn4linux.org  http://www.isdn4linux.org/

Reply to: