[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Second NIC on Alpha XLT-300

I could use some help and/or pointers with a problem I have,
and cannot solve.

I recently came into possession of an old DEC Alpha XLT-300.
I brushed the dust off and fired it up and it worked fine.
I then loaded the most recent version of Debian (2.2r2) for
the Alpha on it and proceeded to experiment.  Everything
worked fine and as advertised, but the built-in 10 Mbs
ethernet NIC did not match the rest of my home network, and
I decided to add a second NIC.  That is where the problem
started.  I cannot get the second 100 Mbs NIC to work.

The first added NIC I tried had a Realtek 8139 chipset.  The
computer would recognize it and it would work for about 10
seconds before it would cause a kernel panic and a hard
freeze requiring a push of the reset button to reconver.
Right after the hard freeze-up the console window would be
filled with error messages about kernel panic and an
inability to synch with the interrupt handler.  I have tried
re-compiling the kernel and modules to remove any extraneous
modules and specify that I was using the "Alcor" sub-type of
the Alpha, and tried the various options in the PCI section
of the kernel config.  Nothing seems to work....the results
were the same.  I have tried the latest drivers for this
card from Donald Becker's site without results too.

The second additional NIC I tried was a Lynksys LNE100TX
that purports to have a DEC "tulip" chipset, or derivitive.
I had a bit more success here in that it works and sets up
OK, BUT a "ping" from the Alpha machine brings up an error
message indicating a bad CRC checksum and consistantly
identifies byte 42 as being the "mangled" one.  Needless to
say I get a 100% packet loss.  Strangely, if I ping the
Alpha from another machine, it appears to respond correctly.
Again I have tried various kernel configs and am currently
using the latest "tulip" modules from Donald Becker's site.
I do NOT get the hard freeze when using this NIC.

During all of the above machinations, the "built-in" DEC
Tulip-based 10 Mbs NIC continued to work flawlessly.

My first thought was that this was something wrong in the
"tulip" NIC module, but considering the fact that the
"built-in" NIC works fine using the same module, I suspect
it is something else.  Considering the regularity of the
location of the bad byte in the "ping" response, and the
message I earlier got from the Realtek chip, I now suspect
something is wrong elsewhere....perhaps in the interrupt
handling routines??

At this point, I am at a loss as how to proceed.  I am
definately NOT a programmer or coder.  I am just your basic
"dabbler" trying to make something work that I think should
work.  I would appreciate any pointers as to how to proceed
and/or where to look.

The Alpha is NOT "mission-critical" to my home network.

Cheers, & Thanks in advance for your time & consideration.

-Don Spoon-

Reply to: