[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: possible glibc bug?

Well, I think I found my bug.  Sorry to bug you guys about it.  I was
free on a pointer that was not at beginning of it's memory block.  I
know why it would only seg fault on the alpha though...

Luke Shulenburger

Luke Shulenburger wrote:

> Hello,
> I am a student taking a c programming class (I'm a fortran hacker) and

> I believe I may have stumbled across a bug in libc for potato.  I'm
> attaching
> my code.  Please be kind as I am quite new at c.  Anyway, if I run the

> program,
> tell it that I have 2 variables, t=0.0, y1 = 1.0, y2 = 10.0, RTOL =
> 1.0e-5,
> ATOL = 1.0e-200, I have no problems, the program exits normally.  If
> I give it
> the exact same inputs, but change RTOL to 1.0e-7, the program dies
> a
> seg fault.  I thought this was interesting, so I tried running it in
> and it said that
> the program died like so:
> Program received signal SIGSEGV, Segmentation fault.
> 0x2000011fb04 in chunk_free () from /lib/libc.so.6.1
> I tried several things to clear this up, but couldn't figure it out,
> I tried using
> ccc instead of gcc and got the same thing.  The thing that led me to
> think it
> might be a bug in the alpha version of glibc is that I took the same
> code and
> tried compiling it and running on an x86 running woody.  There were no

> problems
> when I tried that, I also attempted to compile it and run it  using
> on a sparc running
> solaris.  Once again, I could not reproduce the same errors that I had

> gotten on
> my alpha.
> Here is what information on gcc and the various libraries that I could

> scrape together
> for the different machines:
> my alpha:
> gcc: version 2.95.2 20000220 (Debian GNU/Linux)
> libc: libc6.1_2.2-5_alpha.deb
> the x86 box:
> gcc version 2.95.2 20000220 (Debian GNU/Linux)
> libc: glibc Version: 2.1.94-3
> I can't get the c library version on the solaris box, but the gcc is:
> gcc version 2.95 19990728 (release)
> Like I said earlier, I'm quite new to c, so this is in all likelihood
> just a programming
> error of mine that for some reason only manifests itself on alpha.
> Please be kind.
> And don't bother sending me corrections on the homework, first, I know

> this is not
> the place for that and second, it was already due :-)
> Luke Shulenburger
> (sluke@mit.edu)

Reply to: