[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dd bug or cdrom driver bug???

On 27 Jul 2000, Alan P. Kennedy, Sr wrote:

> I was reading the cdrom writing howto and the howto gave a demo on how
> to copy a data cdrom directly to the harddisk. I tried this on an
> alpha and got the following result with /dev/scd0, and I also tried
> /dev/hda and got the same result. Both devices are cdroms and they
> work fine. It appeared that the system was locked for a short time but
> the system started responding after the command was complete.
> dd if=/dev/scd0 of=cdrom.iso bs=8192
> dd: /dev/scd0: Input/output error
> 0+0 records in
> 0+0 records out
> 0+0 records in
> 0+0 records out
> dd: /dev/scd0: Bad file descriptor
> Of course I tried the same thing on my aging pentium pro (32ia) and it
> worked perfectly with all cdroms installed. 

Works fine on my SX (have an EIDE CD-ROM, but that's the only
difference).  Sure you have the correct device?  Check /proc/scsi to make
sure the device is being mapped to /dev/scd0 (looks like it's not from the
above input, since it's saying that '/dev/scd0' is a bad file descriptor).

FWIW, here's my command line that I used (again, EIDE CD-ROM):
	dd if=/dev/hdc of=cdrom.iso bs=8192


Reply to: