[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: potato alpha install experience...

Brian Macy <bmacy@siteROCK.com> writes:

> - Installing kernel and modules kind of worked... it worked but it
> didn't increment to the next step

Yeah, that's because it installed an uncompressed kernel as
/boot/vmlinux, but the main menu code looks for /boot/vmlinuz in order
to determine whether the kernel is installed.  Now it installs a
compressed kernel as /boot/vmlinuz (the PowerPC people are going to
have to fix this eventually since they use uncompressed kernels)

> - The tulip driver only got installed if I manually modprobe'd it myself
> or forced it via Configure Drivers

I presume you used the 2.2.8 disks then.  Try the ones I put on
http://www.debian.org/dhd, they have the de4x5 driver built in.

> - aboot didn't install... still not sure why (I left 4megs at the start
> of the disk for it)... but the rescue was easy enough

Yeah - again, fixed on the pre-2.2.9 disks

> - the default aboot.conf was setup really weird... I installed to sda1
> but it was setup to boot off of sda2

Yes, dbootstrap runs abootconf to set the default partition, and
doesn't put the partition number in aboot.conf.  So if you installed
aboot manually, you got the default of 2.

> - doing an swriteboot /dev/sda bootlx still didn't get me a device where
> I could 'boot dka0' but 'boot dka100' works so I'm assuming it's just my
> ignorance of aboot

The new aboot's swriteboot preserves the old default partition when
it's run.  In your case it seems this wasn't much of a feature :)

> - dhcp/pump don't work... I'll probably do some debugging on this to see
> what I can do

In dbootstrap, or after the initial boot?  The latter is a known
problem - because the netbase maintainer hasn't incorporated the patch
I sent to make it build on Alpha yet ... probably he's waiting to fix
the other bugs before releasing a new package.

> - Multia's are *not* Y2k complaint in any sense of the word. Setting the
> date in SRM yields 1980. After rebooting (even if the date was set in
> the hardware using hwclock) the date is read from the hardware as 2176.
> If I use hwclock to write it to the hardware and read it back (without
> rebooting) it is correct.

That's because hwclock is really, really stupid.  The kernel's RTC
driver knows how to guess the console epoch correctly, but hwclock
seems to think the SRM epoch is 1900 (it's 1952), and then "windows"
the number it gets.  This should get fixed soon, I hope...

> - I've figured out how to set the default when just 'boot' is executed
> in the SRM but I haven't figured out a way to get it to auto-boot to
> it... preferably with a delay before it's executed but I'd live with
> just automatically booting into it.

set auto_action boot

See the updated SRM HOWTO in /usr/share/doc/aboot for more info...

David Huggins-Daines, Senior Linux Consultant, Linuxcare, Inc.
613.562.1239 desk, 613.223.0225 mobile
dhuggins@linuxcare.com, http://www.linuxcare.com/
Linuxcare. Support for the revolution.

Reply to: