[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: compaq c

Luke Shulenburger <sluke@bartender.mit.edu> writes:

> hello,
> I noticed that somebody mentioned they used the compaq c compiler to
> compile emacs under slink.  I have an LX running potato and have several
> codes that I am using which could greatly benefit from a speed boost so I
> downloaded the rpms from compaq's site.  I used alien on them and
> everything seemed to install fine.  However, when I tried to compile a few
> things I ran into the following messages: 
> cc: Severe: /usr/lib/compaq/ccc-6.2/alpha-linux/include//stddef.h, line
> 23: Cannot find file <stddef.h> specified in #include directive.
> (noinclfilef)
> #include_next <stddef.h>
> cc: Severe: /usr/include/math.h, line 289: Cannot find file <float.h>
> specified in #include directive. (noinclfilef)

Have a look at
/usr/lib/compaq/ccc-6.2/alpha-linux/bin/comp.config. Perhaps there are
some paths wrong, at least I had to edit it (I didn't use alien, but
installed manually). Mine does currently look like this:

  | -SysIncDir /usr/lib/compaq/ccc-6.2/alpha-linux/include -SysIncDir /usr/local/include  -SysIncDir /usr/alpha-redhat-linux/include -SysIncDir /usr/lib/gcc-lib/alpha-linux/2.95.2/include -L/usr/lib/compaq/ccc-6.2/alpha-linux/lib -L/usr/local/lib  -L/usr/alpha-redhat-linux/lib -L/usr/lib/gcc-lib/alpha-linux/2.95.2

(all on one line) for an up-to-date potato system; you might need a
different gcc-lib path if you have an older gcc.


Reply to: