[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apt-get upgrade dies badly ...

On Fri, 29 Oct 1999, Michael Neuffer wrote:

> * Andrew D Lenharth (adl@cs.washington.edu) [991028 23:00]:
> > I have had the same problem on a multia (noname).
> > ls was giving the same problem (Illegal instruction), but that has gone
> > away.
> Do you remember what you did to make it go away ?
> I don't want to reboot the box as long as I don't know that it will come up
> again, since it is also the endpoint of my leased line. (Yeah I know
> running unstable on such a box is stupid, but well :-)
> THis morning I simply put the broken libc6.1 on hold and tried an update again.
> Before the update of the libc6.1 would fail with segfaults.
> Here first the update of ldso fails with an Illegal instruction, then
> installs correctly as it seems. 

I was first trying to reistall my alpha using the base from slink, then
upgrading to potato (do we have a base for potato yet? we should. is
anyone working on it?).  the libc6 failed with ilegal instruction.  I then
put my old arddrive back in, and tried to update it (it had potato as of
about a month ago).  This to failed.  Same problem.  After this, various
other prgrams started failing (ls was the most anoying :).  I tried making
a chrooted install dir on the other drive to install potato there, but
still had the same problem.  libc6.1 in it's current version just refuses
to run on my multia.  I haven't tried my new (233 ;) alpha though, still
need to find him some ram.

Andrew Lenharth

Reply to: