[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Speaking of dselect...

CCC asks:

> Speaking of which, has anyone used dselect on Alpha lately?  I haven't and
> was wondering how 'dselectable' our tree was at this time.  Last time I
> tried, there were still some broken perl dependencies, but I think I've
> rebuilt everything that might cause problems that way.

Yes, I am using dselect (with the apt method, of course, but still).  My
alpha has just been updated to potato and runs well; the only conflicts I
have at the moment are the following that seems to be known already:

* bsdutils does not install because it overwrites /bin/kill from procps
* gnome-apt depends on libapt-pkg2.5 which does not appear to be available
* figfonts depends on figlet (>= 2.2-9) but the available version is 2.2-8
* exim.conf had two bad lines in it after "automatic" upgrade

Thus nothing serious.

I upgraded from slink by

1. Installing and testing milo-981104-Miata with kernel 2.0.35

2. Compiling kernel 2.2.12.

3. Rebooting into kernel 2.2.12.

4. Point apt to potato by using the following /etc/apt/sources.list:

deb http://ftp.fr.debian.org/debian potato main contrib non-free
deb http://nonus.debian.org/debian-non-US potato main contrib non-free
deb-src http://ftp.fr.debian.org/debian potato main contrib non-free
deb-src http://nonus.debian.org/debian-non-US potato/non-US main contrib non-free

   (well not quite: I use a local mirror but I could use the above).

4. Running apt-get [-f] upgrade until it makes no progress.

5. Running apt-get [-f] dist-upgrade until it worked (this felt shaky :).

6. Running apt-get upgrade until everything was more or less stable (well,
   I had to download some gnome packages manually for it to work...).

So I'm happy and the machine, a PWS 500a, running well (except for a few
keyboard lockups in gdm that I could not really track down).  BTW, it can
do compilation once a buildd is up, if anyone wants that.

Best regards,

PS. One thing is strange, though: the `bug' command invariably exits just
after asking about the single line describing the problem so I have not
submitted so many bug reports recently :)

Kristoffer Høgsbro Rose, phd, prof.associé  <http://www.ens-lyon.fr/~krisrose>
addr. LIP, Ecole Normale Supérieure de Lyon, 46 Allée d'Italie, F-69364 Lyon 7
phone +33(0)4 7272 8642, fax +33(0)4 7272 8080   <Kristoffer.Rose@ENS-Lyon.FR>
pgp f-p: A4D3 5BD7 3EC5 7CA2 924E D21D 126B B8E0   <krisrose@{debian,tug}.org>

Reply to: