[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: kernel problems

On Mon, 4 Oct 1999, Luke Shulenburger wrote:

> I am running potato on an LX and I have recently been having some
> interesting problems.  I have upgraded to the 2.2.12 kernel, but the
> computer seems to think that I am still at kernel version 2.2.7.  (At
> least that's what /proc/version tells me)  I compiled the kernel by hand
> and am sure that milo booted off of it.

MILO didn't use it to boot off of, fyi.  /proc/version is always correct.
The way I juggle kernels is to copy the images into / and name them
appropriately (eg. vmlinux.2212.gz, etc).  From there, since I have an SX,
I make a new boot selection in AlphaBIOS so that it passes the correct
boot command to MILO (with the correct new kernel image name inserted) and
make it default.  Later on, I go back and delete old entries and kernels.

If you don't have the environment stuff set up in AlphaBIOS/ARC, though,
make sure you boot using a milo command like:
   boot sdb1:/vmlinux.2212.gz root=/dev/sda1

> I also get this strange error
> whenever I run top:
> Warning: /usr/src/linux/System.map not parseable as a System.map
> Warning: /System.map has an incorrect kernel version.

Make sure to copy the System.map file that is built with your kernel to /
or create a softlink to it's real location.  Also, make sure that your
version of procps is updated.  There was a problem in a previous version
that caused top or ps to display that message all of the time, even if
System.map was up-to-date.

> I originally decided to upgrade the kernel because when I installed the
> oss package to get my sound card (AWE64)  working, I was no longer able to
> print. I have checked the io ranges and interrupts that my alphabios
> believes the soundcard and lpt1 are at, and they do not conflict at all.
> Also in this newest kernel I turned off plug and play support because the
> only plug and play card I have is the sound card.  I did this to prevent
> the sound card from initializing, but my problem was not solved.  Any help
> you might offer would be appreciated.  Also, if this is not the proper
> list for this question, please direct me to a more suitable one.

This, I'm stumped on with the current info given. What kind of Alpha do
you run?  Also, email me (not the list) a copy of the .config and I might
be able to tell what happened...


Reply to: