[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ssh problems...

On 8 Aug 1999, Mikolaj J. Habryn wrote:

{>>>>> "LS" == Lonnie Sauter <sauter@math.ukans.edu> writes:
{    LS> As you can see the destination never responds.  So I tried
{    LS> rpcinfo in an attepmt to get some help.  When I run rpcinfo -p
{    LS> compute9 the program never returns.  So could this be some
{    LS> portmap problem?
{  What do you see when you strace the hanging program? If you have
{console access to the machines, can you log in there to a machine that 
{doesn't respond to ssh? What do you see if you strace the sshd on that 
{machine while you're trying to ssh to it?

>From what I can tell there sshd is already running on a host you ssh to.
When one submits a request for ssh connection, another sshd will start.
This is NOT happening on the machines.  Only the original sshd is running.
I have tried, of course, to restart sshd via /etc/init.d/ssh restart (and
I did it manually also).  For some reason the sshd on the remote seems to
not be responding.  

I did strace the sshd on the target host that does not work correctly:

(61) # strace -p 15044
select(4, [3], NULL, NULL, NULL

It does not react when a ssh session is requested.

On a working host this is what happens when a connection is requested:

select(4, [3], NULL, NULL, NULL)        = 1 (in [3])
accept(3, {sin_family=AF_INET, sin_port=htons(1010),
sin_addr=inet_addr("")}, [16]) = 5
fork()                                  = 2543
gettimeofday({934144722, 721215}, NULL) = 0
gettimeofday({934144722, 721290}, NULL) = 0
gettimeofday({934144722, 721344}, NULL) = 0
times({tms_utime=5767, tms_stime=39, tms_cutime=38508796,
tms_cstime=1344}) = 188295075
times({tms_utime=5767, tms_stime=39, tms_cutime=38508796,
tms_cstime=1344}) = 188295075
getrusage(RUSAGE_SELF, {ru_utime={5, 631835}, ru_stime={0, 38085}, ...}) =
getrusage(RUSAGE_CHILDREN, {ru_utime={37606, 246093}, ru_stime={1,
312500}, ...}) = 0
getxpid()                               = 114
getxpid()                               = 114
getxuid()                               = 0
getxgid(0x1201423e0)                    = 0
close(5)                                = 0
select(4, [3], NULL, NULL, NULL <unfinished ...>

Thanks for the help!


Reply to: