[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ipfwadm: setsockopt failed: Invalid argument

On Wed 23 Dec 1998, Paul Slootman wrote:

> I found a ref in dejanews on how to fix this. netinet/ip_fw.h apparently
> defines byte and packet counters as 32-bit values, while they are 64-bit
> on Alpha (probably a glibc bug? I mean the header file, not the size
> itself). Anyway, has anyone else tried to fix this yet, and failed,
> before I try it?

OK, I fixed it... I've built a new version of netbase which was uploaded
*just* too late for today's dinstall run. Anyway, ipfwadm now works.

On a related note, I also did a sourceful NMU of netstd, as the patches
to identd (related to the alignment traps) had not been added. I also
had to change the version number, as it was 3.07-7slink.1 and that was
considered a downgrade compared to 3.07-7.1 ... It's now
3.07-7.1.slink.1 :-)  Unfortunately this one was also too late to be
installed today. On the other hand this opens a time window for some
discussion on debian-devel in the meantime :-)

Paul Slootman
home: paul@wurtel.demon.nl | work: paul@murphy.nl | debian: paul@debian.org
http://www.wurtel.demon.nl | Murphy Software,   Enschede,   the Netherlands

Reply to: