[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Comments on installation (boot-floppies 981115, mirror 981120)

Paul Slootman <paul@wau.mis.ah.nl> writes:

> I burnt a cdrom of sid as of 981120, with the boot-floppies of 981115 on
> it. I only now had a chance to try it out (on my udb / multia). Here are
> a couple of comments:
> - Mounting the ramdisk (loaded from the root1440.bin) gave a message
>   about "too long since last check, e2fsck recommended". Not a problem,
>   but very strange for a ramdisk :-)  Maybe that fs should be modified
>   with "tune2fs -i 0"...

Not strange at all. The ramdisk was last checked around
1998. Currently (after booting :) we have 2018. I think its fine to
check a 20 year old ramdisk. :)
The problem is the cklock, is off some 20 years and thus the error

> - The root1440.bin image and the base system don't have /dev/scd0. One
>   needs to create this by hand to use the cdrom to install the base
>   system etc from cdrom: "mknod /dev/scd0 b 11 0" (and again after
>   rebooting from the hard disk).

Same with sda8,... and sdc,... There are not enough device entries
present. Same with the base.tgz, after rebooting you have to do the
same again.

> - In "configure base system", the following appears as an error through
>   the screen:
>     /target/usr/share/keytables/us.map.gz: No such file or directory

Yep, I had the same, but with the german keymap. Thats a nasty bug.

>   This maybe also causes the problems after rebooting from hard disk,
>   where before asking for the root password, you get to select a
>   keytable, and the first selections are "arm i386 sparc ..."
>   (approximate; no "alpha" in that list however). This is really weird.
>   It then gives some error, and sits there. I waited a while and then
>   hit enter. It then resumed the normal procedure (asked for root
>   password, etc.).
>   It looks like this is a problem with the kbd package, as something
>   similar happened after dselecting all the stuff and kbd was
>   configured.

For me kbd-config was started and wanted to switch back to the kernel
default map, which failed, so it tells me that it will switch back to
the kernel default map, .... and so on for ever until I killed it.

> - Choosing "mountable" doesn't mount the cdrom during the config of that
>   access method, even though it says "OK". Even after I had fixed
>   /etc/fstab and /dev/scd0 so that I could manually do "mount /cdrom" it
>   still didn't actually mount the cdrom on its own. Mounting it by hand
>   from another VC worked (the mount doesn't work, but as it's already
>   mounted it's not a problem).

Doesn't that read "mounted" filesystem? That would mean that its
already mounted and not that it will be mounted. "cdrom" should be its 
own entry. Maybe theres also a "mountable - not yet mouted". One must
be carefull not to mix the both. I installed from a "already mounted"
filesystem, which contained a alpha mirror, which worked.

May the Source be with you.

Reply to: