[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Alcor installation and kernels etc

On Thu 26 Mar 1998, Tan Wee Yeh wrote:
> Paul Slootman wrote,
> Ouch.. I gzipped the binary :PP.  Anyway, I tried the
> compilation again after installing gcc2.90.26 (egcs).  Now,
> it won't link properly:(.  The errors occur in the linking
> as shown below.

You didn't show the errors, only the link command...

> Errors seem to be located around the msdosfs supports since
> taking them out works... Compiling the fatfs as modules
> gives problems when loading:
> prata# insmod fat.o 
> fat.o: unresolved symbol load_nls
> fat.o: unresolved symbol load_nls_default
> fat.o: unresolved symbol unload_nls
> fat.o: unresolved symbol utf8_wcstombs
> Any ideas??

Maybe "modprobe", as apparently 'fat' needs some other module (did you
select one or more of the NLS modules?)

> Also, the problem with the alignment traps only occur when I
> up the tulip cards.  There are 2 devices here, eth0 and
> eth1... the system default eth0 has no problem (possibly due
> to that the card is not connected).  Once I up eth1, the
> kernel messages starts appearing...

I also got alignment traps with the network when I used the 2.0.x
kernel. This was fixed when I used 2.1.x.

> :> kernels (2.1.85 and 2.1.90) wouldn't compile at all.  I
> :
> :AFAIK that's a compiler problem, I couldn't compile 2.1.87 either at
> That's what I tried after reading one of the Feb articles
> from the list archive.  Unfortunately, the error remains:
> gcc -D__KERNEL__ -I/usr/src/linux-2.1.87/include -Wall
> -Wstrict-prototypes -O2 -fomit-frame-pointer -D__SMP__ -pipe
> -mno-fp-regs -ffixed-8  -c -o init/main.o init/main.c
> In file included from init/main.c:17:
> /usr/src/linux-2.1.87/include/linux/sched.h:107: parse error
> before `tasklist_lock'

Ah! You didn't comment out the "SMP = 1" line in the Makefile!
Do that, and to be sure do "make dep; make clean" again.

> :I have an XLT with a Matrox Millenium, and it works fine. Very fast.
> :I use 3.3.1 from hamm and X works fine (as long as you don't try > 16bpp).
> Why's that??  Any experience with 3.3.2 (w/ matrox II
> support?  I'm quite keen on getting it.. maybe this Saturday

When I tried 24 bpp (or was it 32) the screen went black, although it
apparently still got its sync signals, and that was the end of the
machine; it was totally locked up. I think it wasn't even pingable!

I've started downloading the 3.3.2 sources, but I'm not there yet. I've
also been spending time getting ISDN to work (the lowlevel stuff is now
working, the network stuff isn't).

Paul Slootman
home: paul@wurtel.demon.nl | work: paul@murphy.nl
http://www.wurtel.demon.nl | Murphy Software, Enschede, the Netherlands
Support Randal Schwartz!
See http://www.lightlink.com/fors/ or send empty email to fund@stonehenge.com

To UNSUBSCRIBE, email to debian-alpha-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: