[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

The ppp-under-2.0 saga.

I've been trying to get ppp working with 2.0 kernels.

(I need to use a 2.0 kernel because I need to do PCMCIA development, and I
can't get the PCMCIA utilities to work with any 2.1-series kernels on the

I had this working a while ago.  When I first tried Debian/Alpha, my main OS
on this system was RedHat 4.2.  Its pppd worked.  The Debian one didn't, so I
copied the RedHat one over and all was well -- I assumed it'd get worked out
so it'd work under Debian too.  Since then, I nuked my RedHat install and
reinstalled the whole system with Debian from scratch.

No pppd package I've tried works.  So, I grabbed the original, unmodified
ppp-2.3.3 source tree, and it exhibited the same problem.  RedHat's pppd is
only up to 2.2.0f, so I thought that might be it.  I couldn't compile 2.2.0f
easily with the headers that come with Debian.

So, just a few minutes ago, I grabbed the ppp RPM from RedHat 5.0.  I used
rpm2cpio to extract the pppd that comes with it.  Doing an ldd, I saw that it
used the same shared library conventions as Debian (eg. libc6.1 instead of
libc6).  I tried it.

Same failure mode.

So, I grabbed the ppp RPM from RedHat 4.2.  I extracted the pppd.  This time,
ldd told me it used libc6 and ld.so.1, which weren't present.  I just created
symlinks to the current versions.

It worked.  I'm using pppd with a 2.0 kernel now.

Unfortunately, this pppd does not work with 2.1 kernels.  It looks to me like
there may be just no easy way to get a pppd that works under both 2.0 and 2.1. 

(By the way, the exact failure mode, in *all* the failed cases, was that PPP
would connect, and then drop the connection complaining about routing

So, I'll use my temporary hack when I have to work on PCMCIA stuff.  Once the
PCMCIA utilities work under 2.1 kernels, I'll switch to using 2.1 100% of the
time.  (That reminds me -- hwclock isn't working under 2.0 either.  And yes, I
do have a patched kernel, and the /dev/rtc device is there.  The hwclock
utility starts up and hangs forever until I kill it with a control-backslash. 
Which I have to do twice every time I boot a 2.0 kernel.)

Doug DeJulio                         | mailto:ddj@aisb.org
Ancient Illuminated Seers of Bavaria | http://www.aisb.org/~ddj/

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-alpha-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: