[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Kernel 2.1.68 and above


For anyone who's been trying to keep up and use the latest development
kernels, you'll find that 2.1.68 and above won't compile for you with any
kind of networking support.  I've found the source of most of the trouble
and have submitted a bug to linux.dev.kernel as of linux-2.1.70.

Now, considering that it's now 2.1.71 and it still hasn't been
fixed....who knows how long it will be before it's solved :P

In short, the SO_BINDTODEVICE definition is missing out of one header
file.  It seems to have only been added to the i386 include tree, since
it's missing out of all of the rest of them.  Turns out that one of the
net/core files is including this and uses SO_BINDTODEVICE in a condition,
thereby trying to use a non-defined token/symbol/directive/whatever in a
condition and stopping compilation.  I was going to just patch it and
worry about it later, but I didn't want to guess at which value we could
plug in there and hope it worked :)


TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-alpha-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: