[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Can't compile a kernel ...

On Sat, 27 Sep 1997, Nikhil Nair wrote:

> 5) make   (I'd do `make zImage' on my i586 box, but that obviously isn't
> appropriate here; is this right?)

Correct.  The correct command is "make boot".  I don't understand why this
was changed for us, but c'est la vie :)

> a) Nikita's patches: this is the first thing I tried.  It failed on the
> first file (init/main.c).  I tracked it down to include/linux/types.h -
> this had been patched to add the line
>    typedef __kernel_key_t key_t
> but (i) the typedef in ipc.h hadn't been removed, and (ii) __kernel_key_t
> wasn't a known type.

I just noticed the same thing.  I commented out the typedef in types.h
since __kernel_key_t isn't defined ANYWHERE that I can find.  I figured
it's better to revert to the "old way" of letting ipc.h typedef key_t as
an int.  I was just about to mail Nikita with this one...

> I reversed this part of the patch, and tried again.  This time, the ide-cd
> was broken.  I disabled it in the config, and tried yet again.  *This*
> time the aic7xxx driver was broken: there was some i386 assembler code in
> the new, patched version, which wasn't in the old version ... obviously
> not a good thing.

I've heard about the problem with the aic7xxx driver before.  I'm not sure
there was a way around it, unfortunately short of reverting to the older
driver.  You could try reversing the patch on that one as well.  I hadn't
tried or heard anything regarding ide-cd, though.  I'll have to try that
one soon.

> I gave up on that patch.  At this point, I thought it was the patch's
> fault.
> b)  I then tried 2.0.30 + alpha-patches-2.0.30-0.1 from gatekeeper.  Fell
> over very quickly (init/main.c), complaining about another header file,

I have always avoided kernel patches, personally.  I never needed some of
the changes that they provided until now (with me working on util-linux, I
had to).

> c) As a last resort, I tried plain 2.0.30.  Again no go - kernel/sched.c
> this time.

Really?  Plain, vanilla 2.0.30 works for me.  What kind of error does it
say you're having in kernel/sched.c?

> So I reckon it must be my system.  I'm running a kernel from gatekeeper
> (pc164-2031-test...), I can only think this must be the problem ...

I doubt it.  Also, looking through your list of packages hasn't revealed
anything that I would suspect would cause problems like that.  If you
could, please attach a copy of your .config from your kernel dir.  Maybe
something in there is strange.


TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-alpha-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: