[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Speech-Dispatcher Won't Install


Your response says to me that you didn't follow my instructions.

Uninstall using the voxin installer with -u after it.

Check to see if you uninstalled voxin-up, you were NEVER told to
install it, it has been eliminated, speechd-up is used now.

If you installed voxin-up, purge voxin-up to remove it and any
configuration files.

That will uninstall everything.


Also please note: BRLTTY has its own speech driver for Voxin+IBM TTS,
this speech driver does not rely on speech dispatcher and is not
compatible with Voxin+Vocalizer. (Embedded voices).

If you have brltty installed and want to use your Embedded voice,
uninstall brltty as brltty and Voxin Vocalizer / Embedded are not

Then start the computer again, and install ONE of the following and only one.

1) Voxin IBM TTS
2) Voxin Embedded Alison.

If you're wishing to have Voxin IBM TTS, the easiest way to install it
is by using the voxin emacspeak installer.  Even if you will never use
emacspeak, this installer will check the installation and "make" the
speech server for emacs and install Voxin IBM TTS correctly so it
works in console.

If you wish to have Allison or your other Voxin Embedded voice in
console, follow the instructions in the README inside the archive
containing your purchased voice.

Follow all the instructions EXCEPT add these instructions.

Configure spd-say using root for system wide settings.

You need to do this because you are booting into CONSOLE mode not into MATE.

If you do not do this you will have espeakup in console on log in.

After you using spd-conf as root doing a systemwide configuration,
repeat the command but using your user name following the instructions
in the README file inside your voxin embedded file archive then

Check to see if your voxin and speechd configuration files are all the
same.  Find the files with the correct settings - they will be the
newest dated files.  Copy them and overwrite the older files to update
them.  The files everywhere except your /home folder have to be edited
or moved with root and be owned by root:root not your user account or
things won't work.

I've previously sent you customized configuration files for your
system.  Those will work  as long as the owner is root:root in your
system files and your username in your /home files.

I cannot do more for you - you just don't seem to be able to follow my
instructions because you say "still no IBM TTS or Allison" - if you
followed my instructions you would know that I specifically told you
to uninstall everything and install ONLY one voice, either IBM TTS
US-ENG or your Allison Embedded voice, only one, not two, not three,
just one voice.

You should check and see what voices are installed with voxin-say -L

Best wishes,

On Thu, Mar 17, 2022 at 5:50 PM Chime Hart <chime@hubert-humphrey.com> wrote:
> Hi Both Davids: Thank you, will need to try this, as I followed Davids
> instructions rather carefully, but even after rebooting, still no Voxin nor
> Allison.
> Chime

Reply to: