[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: installing with the debian installer and selecting pam profiles and gdm3 not able to login using the keyboard



Hi, The installer asks about pam profile selection if you install X and the standard system if you use the debconf/priority=low and also after the base system is installed changing the debconf/priority to low on the system that is beeing installed. I also had selected file and printer server but when I uninstalled X I found that the printer server was removed and not all packages from the graphical desktop task are removed as alsa is installed which I of course want to keep even if I remove X but it would be nice if tasksel also purged the configuration files of a package either as a command line switch or in the selection screen. It is tasksel that is asking about the pam profiles not the installer directly. Also upgrading speakup to the latest version would be very useful both for the installer and for the kernels that are installed. Nick Gawronski

On Wed, 6 Oct 2010, Trevor Saunders wrote:

On Wed, Oct 06, 2010 at 09:57:40AM -0600, Nick Gawronski wrote:
Hi,

Hi, I am using the latest testing gtk mini iso image and was installing testing
and chose to install X as well as the standard system.  When the pam profiles
were selected I tried like I did in the other screens of the installer to put
spaces between the numberd options but I get the message that no pam profiles
have been selected and this is not allowed.  I redid the installation just

hmm, when did the installer start asking about pam profiles?  One thing
to try would be to put ',' between the options you want.

installing the standard system and then ran tasksel to install X and the other
packages such as file and printer sharing and got the same issues accept I
pressed space errowed down made sure stars were in front of all of the pam
options and still got the errors.  I then could not cansel this operating so
had to kill aptitude and reboot the system as removing files in /var/lock did
not fix the issue and I ran dpkg --configure -a and just selected unix
authentication.  This time it worked.  Also, gdm3 does not beep at the login
prompt and any keys I press on the keyboard I don't get to a login screen and I
can't login and start speech.  If possible could there be an option in the

doesn't just typing your user name and password work?  That works here
even with the new gdm that doesn't seem to beep which iirc is a bug that
has already been filed.

configuration of gdm3 to enable orca upon login so users could use speech to
login to the system as I can't find any keyboard commands to either login to
gdm3 or where to enter my login information?  Really enabling accessibility for

it should be possible, but I've never configured it.

gnome as the default would be best as if a user did not need speech just don't
start it or if it is started by default they can always turn it off.  Allowing
programs to run with speech output after entering the root password by default
as I can't find how to fix this would also be nice.  Nick Gawronski

the easiest solution is to just run the program from a terminal with
sudo like sudo aptitude update.

Trev



Reply to: