[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem when trying to install gnopernicus package

Mario Lang <mlang@debian.org> writes:

> Nath <nath.ml@free.fr> writes:
> > Today I try to install gnopernicus on a fresh installed Knoppix (debian
> > unstable) on my hard disk. 
> > First I installed the gnome-core package and the suggested packages
> > gnome-control-center, gnome-panel, gnome-session, gnome-terminal and
> > gnome-help. But after this step I tried to install gnopernicus and it
> > doesn't work because it depends on libgnome-mag 1.10 and only
> > libgnome-mag 1.9 is available.
> I guess you are refering to libgnome-mag1 0.10 here?
Oh sory, yes I refered to this package !

> > So my question : what can I do to solve this issue ?
> I'm a bit puzzled why you do not have libgnome-mag1.  What is the
> deb line in /etc/apt/sources.list you are using?
I tried to understand a little mor what is appening and saw that the
problem was in my /etc/apt/apt.conf file. In this file the testing
release is the release indicated as the default release. So, i
understand now why it prefers to install libgnome-mag1 0.9; 
But my problem is now that I don't know which packages belong to testing
and which packages belong to unstable in my installed distro. I never
completely understand how to proceed with apt.conf, priorities etc
... For example I said that I installed gnome-core and the suggested
packages but which debian release are these package comming from ? I
suppose that gnome-core comes from unstable because gnome2 is not
present in testing but all the dependencies installed in teh same time I
don't know where they come from. 
So, I don't know what to do now : Is it necessary to upgrade the whole
distro to unstable by comment the line in the apt.conf file and tehn
make a apt-get dist-upgrade or can I do other things ? If I upgrade the
whole distro I'm affraid to have after that the
debconf/modconf/dialog/wiptail bug we discuss a few days ago !

> > Does it exist an option to tell apt to ignore dependancies ?
> No.  And that wouldn't make sense here, since the program will probably crash
> if it finds libraries it wasn't compiled for.
> > Perhaps libgnome-mag is not so necessary because it seems
> > gnopernicus can work properly without gnome-mag ?
> But gnopernicus links against that library, so it is necessary to be able
> to run gnopernicus.
> > If you have other ideas or solutions ?
> Get the proper version of libgnome-mag1, its in sid.
Yes that right but as I said before how can I do ?
> > Another question : may I install other packages in order to have a
> > working Gnome environment ?
> My parser failed on this sentence, what do you mean?  Another screen reader?
No, not another screen reader but in other words is gnome-core package
(with X installed) enough to be able to start and run Gnome ?

Thanks a lot for your help !

> -- 
> CYa,
>   Mario | Debian Developer <URL:http://debian.org/>
>         | Get my public key via finger mlang@db.debian.org
>         | 1024D/7FC1A0854909BCCDBE6C102DDFFC022A6B113E44


Reply to: