[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Time to re-enable all vim builds on m68k ���


some time ago I asked you to disable building the GNOME version
of vim on m68k due to the unavailability of the former. Well, a
lot of fighting later, it’s building again – full buildd log of
an exemplarily (see below) patched package attached, so you can
review it for any possible other issues if interested.

So please consider re-enabling all flavours in some next upload
(no need to hurry, we’re fine as-is).

--- vim-7.3.547/debian/control	2012-09-16 03:15:05.000000000 +0000
+++ vim-7.3.547/debian/control	2012-12-09 13:36:53.000000000 +0000
@@ -12,8 +12,7 @@
  dpkg-dev (>= 1.15.1),
 # B-D for GUI support
  libgtk2.0-dev, libxaw7-dev, libxt-dev, libxpm-dev,
-# m68k currently can't build the Gnome dependencies
- libgnomeui-dev [!m68k],
+ libgnomeui-dev,
 # B-D for language interpreters
 # Update d/rules when ruby version changes
  libperl-dev, tcl-dev, python-dev, ruby, ruby-dev, lua5.1,
--- vim-7.3.547/debian/rules	2012-11-19 12:51:14.000000000 +0000
+++ vim-7.3.547/debian/rules	2012-12-09 13:36:56.000000000 +0000
@@ -121,9 +121,7 @@
-ifneq (m68k,$(DEB_HOST_ARCH_CPU))
-	VARIANTS+=vim-gnome

I want one of these. They cost 720 € though… good they don’t have the HD hole,
which indicates 3½″ floppies with double capacity… still. A tad too much, atm.
‣ http://www.floppytable.com/floppytable-images-1.html

Attachment: vim_7.3.547-6~1_m68k.build.xz
Description: Binary data

Reply to: