[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: how to install Etch, Lenny or sid?

On Sun, Jan 27, 2008 at 05:25:29PM +0100, Petr Stehlik wrote:
> Hi,
> I have just tried to install Debian but I don't know how to do that. I
> used to be installing from CD images but I can't find any for Etch or
> newer. Please help...

I've made quite a few test runs using aranym and the daily images from 
[1], but installing etch-m68k with the issues listed in [2].

[1] http://people.debian.org/~smarenka/d-i/images-m68k/daily/
[2] http://wiki.debian.org/DebianInstaller/M68kTodo#issues

These notes are for aranym, but should work for atari. Other archs
shouldn't run into most if any of these bugs.

You'll need a 2.6.18 or later kernel (or so) with working ethernet
(NFETH isn't configured correctly in the standard debian kernels atm).

Grab the daily nativehd image from [1].

You'll need to boot with suite=etch-m68k.

I've been running with a preseed that fails at partman. At that point I
go to the shell download and install the partman udebs (udpkg -i) and 
walk through the issues in [2]. 

After that, installation should complete normally. It's a bit of a pain, 
but it works. I've got patches submitted for all of the bugs, I'm hoping
they'll all be uploaded as part of the lenny beta 1 d-i release.

If you want anything more specific, please let me know. I'll try to make 
a test run tomorrow and see where things are at.



Stephen R. Marenka     If life's not fun, you're not doing it right!

Attachment: signature.asc
Description: Digital signature

Reply to: