[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Q: booting Debian 2.6.12-1 on a Q840

On Tue, Oct 18, 2005 at 07:26:59PM +0300, Meelis Roos wrote:
> Hi,
> I wanted to try 2.6.12-1 as packaged by Debian, on my Quadra 840AV.
> I have heard that it should work (modulo hwclock and maybe ADB). So I 
> installed the kernel package, copied vmlinuz and initrd to the Mac 
> partition and tried to boot it with Penguin 19. I specified the image 
> and initrd to Penguin and tried different root= command lines.
> I have root on /dev/sdb4, using ext3. It works fine with Debian 2.2.25 
> kernel.
> Not root= at all gave cannot mount root on (0,0) - OK, expected.
> root=/dev/sdb4 gave  cannot mount root on (8,20) - weird.
> root=/dev/ram and root=/dev/ram0 gave both the same non-zero numbers 
> (probably major,minor of /dev/ram0) and didn't boot either.
> Dmesg shows that it detects my SCSI disks and that it loaded ramdisk of 
> 820 KB in size. Ext3 seems to be built into kernel. What am I doing 
> wrong here?

Actually, ext3 should be in the initrd, but I am not sure if I got the
config right. Did you tell the kernel where to find the initrd? On my Amiga,
I added this to the boot args:
I am sure I had to use something similar on my Q840AV.


Reply to: