[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Solved: Apache no longer executing cgi scripts

Solved my problem.  A bit more Google research pointed me in the
right direction.  It was the suexec feature of Apache 1.3.26 which
was causing my scripts to abort.  I didn't know to check the suexec.log
which told me that the user directory which I wanted to have scritps
run out of needed to protection set to world read-only.

On Sat, Jan 29, 2005 at 10:44:24AM -0600, Lance Tagliapietra wrote:
> Hello,
> I am using Apache 1.3.26 on my m68k box (Amiga).  I just realized that
> my cgi-scripts that I had set up via .htaccess files quit working (there
> may have been a security update to apache?).
> I believe I have the configuration correct to allow scripts, via an
> AddHandler directive in my .htaccess file.  My AIX box at work, with
> Apache 1.3.19, works as expected with the same .htaccess file.
> Using the script error logging feature of apache, it is like my script
> is not even being run.  I have tried several types of scripts, perl, sh,
> and even an executable (hello, world for cgi) compiled with gcc.  All
> run properly from an interactive shell, and permissions are correct.
> One again, they wored properly until recently.  I do apt-get updates
> against security.
> Is anyone else experiencing this problem?
> Thanks,
> --Lance (LanceTag@Luminet.net)
> -- 
> To UNSUBSCRIBE, email to debian-68k-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: