[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: HELP: Amiga 2000, Blizzard 2060---base system install fails!

On Thu, May 09, 2002 at 08:32:29PM +0200, Christer Oldhoff wrote:

> Today I removed the Oktagon controller physically (software deactivation 
> did not do it), and tried to install Linux again.
> This time I got much further, but then reached a point which I couldn't
> get past.

I guess this means the boot-floppies work, the rest is just a "user"

> I used the woody distribution (see my previous messages) and the problem 
> occured when I was asked to enter the source from which the 
> base installation should be performed.

which base installation are you talking about, the kernel drivers and
modules or the "base packages"?

> A total of 6 alternatives were given:
> * /dev/fd0
> * /dev/fd1
> * /dev/sfd0
> * (Festplatte) = hard drive
> * mounted

If its base packages, I usually install via the network, thats not an option
for you? Alternatively you can try the basedebs, but they also have to be on
a partition which is readable by linux-m68k. You do not have to use a FFS
partition, you could use FAT or ext2 partitions as well. Put them on your
ZIP, or write a CD with those files.
> As I chose 'hard drive', the AMIGA partition on my IDE drive where I 
> dearchived the base installation files was not shown as a choice---only
> the first unused and preprepared (but not initialized or formatted) Linux 
> partition.
> I interpreted the information in the FAQs as if a Amiga partition could be
> used, althought it seems a bit strange that Linux should be able to
> read it...?

Of course linux-m68k can read (and write) to amiga filesystems. But you
mentioned earlier that you are using some strange filesystem. Currently only
(a few) original amiga filesystems are supported by linux, should be
mentioned in the FAQ. ffs works, I think even international ffs (was that
the name?), direcory cache may not work, or only read only. You have to
create a partition with a "readble" filesystem, you will need it later when
you want to upgrade your kernel.

> I also tried choosing 'CDROM'---where I had a installation CD-ROM disk
> with the older version 2.2r5 of Debian/m68k---but then I was told that
> the volume couldn't be mounted (Das Einbinden des Datenträgers ist 
> fehlgeschlagen).

You can not install woody with a potato CDROM.

> I supply the output of dmesg in an attachment (the last line about 
> the keyboard selftest only occurs sometimes---I don't think it is 
> relevant). 
> Note that the installation procedure did not freeze this time---I
> can keep going back to the screen where I choose to perform the
> base installation! 

The kernel is working fine now, no new information from dmesg. try 
fdisk -l /dev/hda (or sda) that should tell us the filesystem types. And I
bet some FAQ (or maybe even the installation manual) mentions which
filsystems you can use.


To UNSUBSCRIBE, email to debian-68k-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: