[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: HELP: Amiga 2000, Blizzard 2060---base system install fails!

Hello Christian!

On 02-May-02, you wrote:

> On Thu, May 02, 2002 at 07:56:15PM +0200, Christer Oldhoff wrote:
>> Then the blue screen with the blinking cursor appeared.
> there should really be some text in it. 
Well, there isn't :-(

> Do you have an Amiga monitor, ie
 No, but the Picasso-II puts the Amiga video signal through to my flicker
fixer (well, really the other way around...), so I can display 'normal'
screen modes too.
I already tried the generic install script without graphics card support
with the same result.

> could you try startinstall (not using your clgen card)? Please read
> redme.clgen and play a little with the video options. hmm, no, if you get
> video that should work...
I tried that, but I can give it another shot... 
> but there is the welcome screen? Or only the blue screen without any text?
> It should say Welcome to Debian, blabla, this set of boot-floppies was
> built by Adam di Carlo on blablabla.

No, *no welcome screen*: this is the exact point where I don't get any
further---there is absolutely no text on the blue screen, only the blinking 
Also there is *no reaction to keyboard input*; nothing can be entered and
there is no reaction to pressing ENTER or RETURN
> and you do not get a shell prompt? thats weird.
Yes, indeed...

> dmesg: 
> of course its (also) an amiga program, please see the README.dmesg on how
> to use it. Also my potato FAQ should talk a little about it.
I already had read everything that seemed relevant (Amiga specifics,
hardware, Your FAQ...).
I always have to press Ctrl-Amiga-Amiga twice (I have even waited about
a minute before each) to get the Amiga to boot. I guess this erases every
race that dmesg might have left---it always reports "No SAVEKMSG magic".
By the way, I *do* invoke it before *and* after trying the StartInstallXXX

The docs mention something like 'debug=mem'; is this some switch I have to
turn on in the StartInstall script to get the dmesg output? 

I can try to type as much as possible off the screen, but as You said
before, typos are likely to result...

> Please describe your other hardware, hdd, cdrom, and what you get on the
> screen before linux boots (list of autoconfig devices found). Basically,
> give us all you see. Maybe you are missing a subtle detail...

 My *hardware* is:

- A2000B (manufactured in 1989 and bought in Germany), motherboard rev. 6.2,
- 1 MB Chip RAM, 
- 1 original DD floppy disk drive (DF0:),
- DEInterlace flicker fixer (makes it possible to see all native Amiga
    screens on my: 
- Nokia 44BN multisync monitor,
- Picasso-II (not +) graphics card with 2 MB graphics RAM 
    (running in linear mode),
- Oktagon SCSI-II controller with old Quantum LPS52 (MB) HD---not really
- MultiFaceCard-III interface card with parallel and serial interfaces
    (modem, printer),
- Catweasel S-Class = Buddha IDE controller + Catweasel floppy controller
- Samsung SV2001H 20GB IDE HD connected to Buddha,
- Off-the shelf PC HD floppy drive connected to Catweasel,
- Drives connected to the on board SCSI controller of my accelerator card
     (see below):
  * Pioneer DR-124X SCSI CD-ROM drive 
  * SEAGATE ST52160N 2.1GB SCSI hard drive
  * Syquest SQ3105S 105MB SCSI cartridge disk drive 

- Blizzard 2060/50 accelerator card (new DCE kind---bought end of 2000---not
  from Phase5!) with SCSI controller and 2x16MB + 1x32MB 32-bit onboard
  FASTRAM which are merged into one continuous 64MB block by Blizzard magic 
  at boot time.
  The MAPROM feature is enabled, i.e., Kickstart ROM copied to FASTRAM at
  booting time

Well, that's all I can think of now...

I suspect that the B2060's boot configuration process is pretty
non-standard, since I have not been able to use StatRAM (recoverable RAM
Disk) since I replaced my Apollo 2030 by the Blizzard.


Normally I use OS3.9-BB2 (installed with the script from Amiga Inc.) with
the MMULib 68060 libs, HSML 68060 math libs, Executive scheduler, PoolMem.
I disabled Executive and Poolmem before trying to install Linux.
Most hard drives use the SFS 1.93 FS.
Apart from that, I generally try to use as few patches as possible.

During the process of trying to install the Linux kernel I have also
*booted* the computer *from* a pretty *virgin OS3.1 FD*, only 'enhanced' by
the vendors 68060 libs and a CD-ROM driver.
Clicking on 'StartInstall' instead of the 'clgen' version displays the
graphics more slowly so I can read more, but
*ends with the same empty blue screen*.
The last line I can see for a short time in the scrolling text window
preceding the blue screen begins with 'Init started...'  

At this point,

Pressing lalt-F2 displays the text:
 'Please press Enter to activate the console.'

Pressing lalt-F3 displays the text:
 'May 3: 11:08:33 (none) syslogd started: BusyBox v.0.43

Pressing lalt-F4 displays the last screen of the scrolling text seen prior
to the occurrance of the empty blue screen. The text reveals that all
partitions on all drives were recognized, that the CD-ROM was recognized,
and so on...

As I cannot provide dmesg output at this time, here is at least what AmiBoot
says on startup (beware of typos):

Linux/m68k Amiga Bootstrap version 5.6
Copyright 1993,1994 by Hamish MacDonald and Greg Harp

Amiga model identification:
    Resource `draco.resource': not present
    Chipset: ECS
    Module `Magic 36.7': not present
    Module `kickad 36.57': not present
    Module `A3000 Bonus': not present
    Module `A3000 bonus': not present
    Resource `card.resource': not present

Type a key to continue...

Amiga 2000 CPU: 68060 with internal FPU, ECS

Command line is 'root=/dev/ram video=clgen:'
Vertical Blank Frequency: 50Hz
Power Supply Frequency: 50Hz
EClock Frequency: 709379Hz

Found 6 AutoConfig Devices
Device 0: addr = 0x00ea0000
Device 1: addr = 0x00e90000
Device 2: addr = 0x00200000
Device 3: addr = 0x00ec0000
Device 4: addr = 0x00ed0000
Device 5: addr = 0x00ee0000

Found 1 Block of Memory
Block 0: 0x08000000 to 0x0bf80000 (65024K)
1024K of CHIP memory

The kernel will be located at 0x08000000
Kernel is compressed
Uncompressing kernel image ................done *(actually 51 dots)*

Loading ELF Linux/m68k kernel...
Bootstrap's bootinfo version: 2.0
Kernel's bootinfo version   : 2.0
RAM disk at 0x08dcf442, size is 854K

Kernel segment 0 at 0x08001000, size 1455584
Kernel segment 1 at 0x081645e0, size 80416
Boot info        at 0x08178000

Kernel entry is 0x00002000
ramdisk dest is 0x0beaa5af
ramdisk lower limit is 0x08dcf442
ramdisk src top is 0x08ea4e93

Type a key to continue the Linux/m68k boot...


*The command line argument conflicts with formatting commands of my email*
*Part of it should read: 'slash dev slash ram' with 'slash' replaced by *
*the division sign of the numeric block and no spaces...*

Christer Oldhoff
Email: coldhoff@swipnet.se

To UNSUBSCRIBE, email to debian-68k-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: