[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apt-get question

On Thu, Jan 18, 2001 at 10:05:56PM -0500, Russell Hires wrote:
> I tried the --configure option but to no avail.
with dpkg? dpkg --configure --pending (thats whats executed by dselect I
> Tried that, didn't work. Basically, just the same error message:
> FATAL: s_lock(801b6392) at spin.c:109, stuck spinlock. Aborting.
  ^^^^^ IEEKS! Did you see that one?
> dpkg: error processing postgresql (--configure):
The rest is just follow-up errors... Looks like a kernel problem, or dpkg
problem to me. Which kernel-version, self-built or the debian version?
Which version of dpkg do you use? Did you upgrade libc6 to 2.2 already, do
you have enough mem, diskspace? Sorry, the possibilities are infinite (you
could also check the postgrsql postinst and try to call the programs there
manually, or with strace or gdb or whatever to trace this down).
I think you have to trace this down yourself, or at least give a lot more
information (any unconfigured packages besides postgresql?).


Reply to: