[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: 2.2.10 on Mac IIcx: SCSI doesn't work :-(

On Thu, 10 Aug 2000, Michael Schmitz wrote:

> > > Linux version 2.2.14 (andrew@llama) (gcc version 2.95.2 19991024 (release)) #15 Mon Jul 31 17:55:47 CDT 2000
> > [...]
> > > VIA1 at 50f00000 is a 6522 or clone
> > > VIA2 at 50f02000 is a 6522 or clone
> > > Apple Macintosh IIcx
> > [...]
> > > VFS: Mounted root (ext2 filesystem) readonly.
> > > Adding Swap: 32620k swap-space (priority -1)
> > > Data read fault at 0x43433a20 in Super Data (pc=0x264c0)
> > > Oops: 00000000
> > [lots of errors]
> > 
> > That's basically the same error I get on my SE/30, except that it
> > sometimes happens after loading the default keymap. I hope to get some
> > time to look at it soon. What happens when you use a ramdisk?
> What struck me as odd was the 'interrupts disabled' part in the SCSI
> controller probe message. What's that about? Not that SCSI would have
> worked with ints off, anyway. 

That was my "fix" for SCSI problems on my SE/30. And yes, it did fix it
for a while. When SCSI had interrupts turned on, it gave me an endless
string of SCSI errors, about commands timing out and coroutines not
running and whatnot. So I tried turning off interrupts, and that worked.
It must just poll SCSI or something. I didn't look into it. But then stuff
broke again in the 2.2.16 update. I'm getting different errors now,
usually after activating swap or loading the default keymap. I keep
getting "bad kernel buserrs" like the one above.

But if you turn SCSI ints on, you don't even get that far.


Reply to: