[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kernel 2.2.10 and sonic ethernet chip

> I've tried both, downloading the compiled kernel form the Mac 68k Linux site and
> compile the 2.2.10 kernel from woody with all patches applied.
> When I try to ping a known host, I get :
> sonic_init: failed, status=2f01, or
> sonic_init: failed, status=2f15

Debug the SONIC init code. Hint: add or prolong the udelays between
register accesses, find the critical register access, then figure out how 
to detect a 'SONIC busy' situation that's apparently biting you. 
Double check that the memory you allocated for the SONIC data structures
is properly marked as non-cacheable (nasty mm macros, but a quick and easy
check is to make _all_ RAM non-cacheable in the mm_init() function called
early in kernel setup). 
> (Obviously, the ethernet works well under MacOS)

If I hear that one more time I'll stop replying to that sort of posts
altogether. Obviously, the SONIC driver worked for me, reliably that is,
under Linux 2.0.36 and 2.2.whatsitsface from May 1999. There were cache
mode issues in 2.0.36, and people mostly on Q700 reported trouble with
SONIC in 2.2 but no one ever sat down to investigate it IIRC. 

> Furthermore, there seem to be some problems when rebooting a stack trace and a
> lot of other messges appear on the screen.

Known problem: don't do that, then.
Halt the machine and reset manually. I've wasted some time on that one too
and could not make heads or tails of the whole reboot code. 
> Machine: Quadra 800, 24 MB Ram, 2 discs, MacOS 7.5.3, Debian Linux 2.1

I've run Linux on a Q800, 20 MB RAM for a long time with no trouble. The
driver was ported and debugged on that machine, see? 

> What I need to know is, if this problem requires some changes in the kernel and
> takes some time to be fixed or is only a wrong configuration I did. I have to

The error message indicates a subtle timing problem in the driver init
code. The SONIC core code is shared with MIPS, maybe someone from the MIPS
port emoved the udelays - David should know about that, and he should know
if any endianness issues might be responsible for this problem. I'm not
looking at the code BTW so it might all be nonsense. 

> set up a box as a CVS server and must do it within this week. If I can't do it
> on the Quadra, I have to do it on a Intel box. Please, let me know.

Good luck. If you're experienced enough you could sure fix the driver in a
day or so.


Reply to: