[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

install problems


I'm stumped trying to install Linux on an Amiga 3000, and I'm hoping
you can help.

The basic problem is that the kernel hangs early on during the
boot.  The screen goes grey, and nothing happens until I use

The distribution I'm using is m68k Linux Debian slink (my reading
seems to indicate this is the most stable).  I use Debian on a couple
of i86 boxes.  The instructions I've been following have been

I've downloaded and unpacked
as directed, and moved it and
into an Amiga partition.

I've repartitioned like this:

scsi address 0, lun, fujitsu, m2694es-512, 812A			/dev/sda

Amiga 		Size	Volume		Use	Start	End	linux device
partition					Cyl	Cyl	/dev/sda1
DHA:		  9M	DHA			1	18	/dev/sda2
DH0:		146M	hdisk			19	274	/dev/sda3
DH1:		146M	dh1-disk		275	530	/dev/sda4
NetBSD_Root	146M			BSDroot	531	786	/dev/sda5
DH3:		146M	dh3-disk	source	787	1042	/dev/sda6
DHF:		146M	From-big		1043	1298	/dev/sda7
linux_swap	 32M			swap	1299	1355	/dev/sda8
linux_root	113M			root	1356	1554	/dev/sda9
NetBSD_Swap	145M			BSDswap	1555	1808	/dev/sda10

When I run the StartInstall script I get:

Amiga model identification:
	Resource `draco.resource': not present
	Chipset: ECS
	Module `Magic 36.7': not present
	Module `kickad 36.57': not present
	Module `A3000 Bonus': not present
	Module `A3000 bonus': 0x00f864f8

Amiga 3000 CPU: 68030 with 68881 FPU, ECS

Command line is 'root=/dev/ram'
Vertical Blank Frequency: 60Hz
Power Supply Frequency: 60Hz
EClock Frequency: 715909Hz

Found 3 AutoConfig Devices
Device 0: addr = 0x00e9000
Device 1: addr = 0x0020000
Device 2: addr = 0x0060000

Found 2 Blocks of Memory
Block 0: 0x07f00000 to 0x08000000 (1024K)
Block 1: 0x00200000 to 0x00800000 (6144K)
1024K of CHIP memory

The kernel will be located at 0x07600000
Kernel is compressed
Uncompressing kernel image


Type a key to continue the Linux/m68k boot...

When I press the final return the screen goes grey and stays that way
until I reboot with Ctrl-Amiga-Amiga.

The hardware I have is an Amiga 3000 with an '030.  There are only two

A 2 Meg memory board, etched as "Commodore A2500", but I believe is an
A2502 based on the old paperwork I was able to dig up (serial

And an unknown GVP board that has 4 Megs of SIMS (4 sockets) and 4
more free sockets.  It also has a SCSI controller which has long ago
been disabled through jumpers.  Unfortunately I've misplaced the
documentation for this board, and I can't find any indication of a
model number on it.

The Amiga runs fine in this configuration under AmigaDOS.  But
suspecting some problem with the memory boards, I've tried removing
each board in turn.  The 2 Meg board is too small to load the kernel
and StartInstall says as much.  The 4 Meg board by itself gives the
same grey screen as before.

I've tried adding "debug debug=ser" to the script.  But no serial
output is produced.  I've tried instead "debug debug=mem".  But dmesg
doesn't find any message block in memory.  I infer from this that the
problem occurs in the kernel before it starts to produce its first bit
of debugging output.

I wondered if I had gotten a bad kernel.  Reading on the net, it seems
that the 2.0.x series is the most stable, so I downloaded
vmlinux-Amiga-2.0.36.  Besides being non-compressed the results were
the same.  I'm not sure if this is the same kernel version as
distributed with slink.

In desperation I've tried installing NetBSD.  It too hangs before the
kernel produces its first message.

>From the symptoms can you understand what's going wrong?

Perhaps my understanding of the hardware requirements for m68k Linux
is wrong.  Is there something I'm missing?

Does anyone know how I can identify the model of GVP memory board I

Is there a different kernel I should be trying?

Is there a way to get debugging output from the kernel very early on
in it's operation?  Earlier than 'debug debug=mem'?

I'm wanting to put the system together for a relative who asks for new
and recycled presents rather than new.

Thank you very much for your help,
Brett Wuth  wuth@acm.org wuth@telusplanet.net bwuth@cuug.ab.ca
Box 1251-U, Pincher Creek, Alberta T0K 1W0, CANADA  Tel:+1 403 627-2460
pgp-public-keys@uit.no has mine; Print=E4F8EDEECBE01AD2FA3D8B2D94B1A292
What is the meaning of life?!  Yes.

Reply to: