[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Need Help with Mac II cx

I've been trying to boot slink on a Mac II cx and am not having much luck.
I start Penguin using the Penguin Prefs with the following settings:
    all diagnostic reports enabled
    kernel: linux
    Ram Disk: root.bin
    Don't Disable Video Card VBLS
    Color by Penguin
    Command Line: root-dev/ram MAC5380=4,2 video=font: VGA8X
Penguin and all of the required install files are located in a top level folder (debian) on a 80 Mb Mac partion of a Connor 1.2 Gb drive. The balance of the drive is allocated to a large AUX root partition and an approx 50 Mb. AUX swap partition.
The command line is the default provided by Penguin. I have tried variations, but all with the same result:
Penguin goes through all the system diagnostics, reports "Booting Linux... Please fasten seatbelts" ejects floppy disk and CD ROM and begins detecting hardware.
Everything seems to go well until it gets to the SCSI hard drives.
I have two drives installed: an Apple Quantum 80 Mb and a Connor 1.2 Gb. Can boot either.
Often, the Linux booter does not detect the Connor drive. But even when it does, the end result is the same. Here's the diagnostic output from the booter starting with the SCSI detection:
reset scsi bus
scsi0 at port 50f100000 irq 19
options CAN_QUEUE=-16 CMD_PER_LUN=2 release=1
scsi: 1 host Vendor Quantum model CTS80S Type Direct Access ANSI SCSI rev:v2
detected scsi disk sda at scsi0 channel 0 id 0 lun0
scsi0: warning: target bitmask 00 lun0 not in disconnect queue
scsi0 reselection after won arbitration?
scsi aborting due to timeout: id:3, scsi0, channel 0, id 1, lun 0, inquiry 00 00 00 ff 00
scsi0 aborting command
scsi 0 destination target 1, lun 0 command=inquiry 00 00 00 ff 00
NCR5380  coroutine is running
status reg 6c, BSY, REQ, CO, IO
scsi0: phase STATIN
NCR 5380 core release=7
BaseAddr: 0x00000 IO_PORT:50f10000 IRQ 19
NCR5380 coroutine is running
scsi0: no currently connected command
scsi0: issue_queue
scsi0: disconnect_queue
scsi0: warning: scsi command probably completed sucessfully before abortion.
and there it hangs.
Any guidance would be appreciated.

Reply to: