[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Some problems... + fetchmail

> This is my .fetchmailrc file:
> poll popmail.libero.it
> protocol POP3
> username rygar@libero.it
> password *
> keep
> smtphost mail.libero.it
> If I delete the smtphost entry in the .fetchmailrc file this is the output:
> fetchmail: syntax error, command unrecognized
> 2 messages for rygar@libero.it at popmail.libero.it (8068 octets)
> reading message 1 of 2 (3947 octets) .fetchmail smtp connect to localhost
> failed: connection refused
> fetchmail: smtp transaction error while fetching from popmail.libero.it
> fetchmail: query status=10
> Well I think that whit the smtphost entry, the program can read correctly the
> messages.

Yeah, but it forwards them to your smtphost for delivery. I really wonder
how you manage to _not_ get a mail loop that way. 

> I tried whit the verbose option (-v and -v -v) and I saw that it reads the
> message on the pop3 server but I can't understand where it saves them on my
> harddisk.

It didn't. Set up a smtp server (sendmail, exim, whatever) on your machine
for fetchmail to talk to. 
> I tried to telnet to my localnet ( it is right!?) but I can't do
> anything because I can't connect to that IP address. I can use smail to send
> messages, but I can't use it to receive them in my mailbox which is located in
> the
> directory /var/spool/smail/root

Time to run smailconfig I guess. But first fix your 'cannot connect to
localhost' trouble - if it is even real. Usually, Debian comes without
telnetd enabled. telnet _to_port_25 (telnet localhost 25) to see if
there's a smtp server running. 

And, please, if all of this sounds just too strange, get a book on Linux
system administration and read up on the concepts of TCP ports, servers
and the like. On top of reading the fetchmailrc man page and example. 


Reply to: