[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Some problems...

> On Fri, Dec 03, 1999 at 04:36:58PM +0100, R.S.L. wrote:
> > Ciao Chris, 
> > I tried to resolve my e-mail problem.
> > This is my .fetchmailrc file:
> > poll my_popserver
> > protocol POP3
> > username my_username
> > password my_password
> > smtphost my_smtphost
> > keep #because I don't want to delete messages on the server
> looking good, only what is smtphost good for? Do you need that?
> > Well, when I type the fetchmail command, it tells me how many messages it
> > receives but after I don't know where I can read them.
> Does it retreive them or not? I get this:
> [...]
> fetchmail: POP3> RETR 30
> fetchmail: POP3< +OK 2703 octets
> reading message 30 of 32 (2703 octets)
> #*********** not flushed
> fetchmail: POP3> RETR 31
> fetchmail: POP3< +OK 1004 octets
> reading message 31 of 32 (1004 octets)
> #********************************** not flushed
> fetchmail: POP3> RETR 32
> fetchmail: POP3< +OK 2234 octets
> reading message 32 of 32 (2234 octets)
> #******************** not flushed
> fetchmail: POP3> QUIT
> fetchmail: POP3< +OK Pop server at sam signing off.
> You have mail in /var/spool/mail/cts
> And it even tells me where my mail is, cool, isnt it? Normally mail is
> put in /var/spool/mail/<account> unless you use the mda as in the procmail
> example. No mda line (like I do it at home) and the mail is in var/spool/mail
> Id say drop the smtphost line, Im not sure what its good for, and I dont
> want to look it up for you. Maybe you have set a limit for mail to retrieve,
> you can make fetchmal skip messages larger than a certain size, but that
> would have to be in your fetchmailrc then I think.
> > P.S.: Instead I can send messages using smail, and mutt.
> Completely different issue, sending mail does not matter for receiving mail.

You might not have noticed this, but this is how fetchmail works.

The description is "fetchmail is a mail-retrieval and forwarding utility".

It picks up your mail then, if you don't have an smtphost setting, it
will deliver to localhost:25 (where you smtp services should be running).
Therefore it will adhere to any further rules your local mail transport
agen (MTA) has about your mail, such as any .forward files or filters.

This is how it ends up nicely in your local mailbox.

So you also need to have sendmail or any other MTA qualifying package
installed allowing delivery from localhost, then if it's still not
working, even though it shows it being transfered, you might be able to
spot some smtp configuration problem by reading the mail.log.  Of
course he might not be delivering it to his local machine therefore he
has the smtphost line set to deliver elsewhere.

You can also turn on debugging in the .fetchmailrc which will help in
terms of fetchmail problems.

Steve Hardman

Reply to: