[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian/Mac and serial ports

>The kernel doesn't do any initilization like on the PC for standard serial

Sure it does!  Or, its supposed to.  In this case it is apparently NOT
doing it.  The script does not run, thats for certain.

>Did you find kermit and try it?
No, I didn't look for it yet.  I don't expect the behavior to be any 
different anyway.  The problem is that the ports are not being setup
at boot time, so they're not yet initialized and functional when I run
minicom, and thats why I have to select it and change something because
the result of doing that init's the port and it starts working.  Kermit
will make no difference.

> wo> I don't even think the script that should run, gets called, and I
> wo> don't know why.
>I not yet familiar with the debian way of doing things (on the pc I use 
>redhat) but you could try /etc/rc.d/rc.serial which is called from rc.sysinit

That is not what happens in Debian's init...and I have no idea what is
supposed to run this script in the first place, but it has to be one of
the Sscripts for runlevels two or three.  I just haven't looked at all
of them to find which it is...whichever one it is, it isn't doing it 
anyway...so I might not find it there afterall.  If its not there, looking
for it will do no good.

Whatever, but since I've already tried setserial, which is really what is
run by the script, it doesn't work with the Mac ports either, apparently.
Setserial is intended to talk to UARTs and since Mac serial ports are not
UARTs it doesn't work, is my guess.  It certainly doesn't write the Mac
ports registers, because if it did the port would work after running it, 
and then launching minicom.  It doesn't.  Not until you do it with minicom
>You could try to just hardcode the lines in a script that _is_ used during 
>boot just to test things.
Its easier to just toggle something once you've started minicom to tell
you the truth.  I don't know what I'd use in the script in the first place
since setserial doesn't work.


Reply to: