[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: growisofs +R Double Layer -dvd-compat burning problem

Andy Polyakov wrote:

~$ growisofs -dvd-compat -Z /dev/dvd=happily.iso
Executing 'builtin_dd if=happily.iso of=/dev/dvd obs=32k seek=0'
/dev/dvd: splitting layers at 1860864 blocks
SK=5h/ASC=26h/ACQ=00h]: Input/output error

~$ dvd+rw-mediainfo /dev/dvd
INQUIRY:                [HL-DT-ST][DVDRAM GSA-4167B][DL12]
 L0 Data Zone Capacity: 1860864*2KB, can still be set

... But then above would mean that *despite* the fact that unit terminated "SEND DVD+R DOUBLE LAYER" command with given error code, the layer break position *was* in fact set anyway. To double-check could you locate plus_r_dl_split function in growisofs_mmc.cpp and modify the end of this function as following:

if ((err=cmd.transport(WRITE,dvd_20,sizeof(dvd_20))) && err!=0x52600)
        exit (FATAL_START(errno));

Recompile and try to burn. Don't forget to provide dvd+rw-mediainfo for resulting recording.

Now, everything works until the end and then I get

5900369920/5900828672 (100.0%) @1.5x, remaining 0:00 RBU 1.4%
builtin_dd: 2881264*2KB out @ average 1.5x1385KBps
/dev/dvd: flushing cache
:-[ SYNCHRONOUS FLUSH CACHE failed with SK=3h/ASC=A0h/ACQ=80h]: Input/output error

This is vendor-specific code and only LG knows what does it mean. Double-check their site for firmware updates for your unit.

As per your suggestion, I upgraded the firmware (now DL13). The released growisofs 6.1 still does not work but the modified growisofs does work ! However, neither my Shinco or Yamaha DVD player would read the disk. However, when I preceded the growisofs command with the following command from your web site

dvd+rw-booktype -dvd-rom -unit+r /dev/dvd

the DVD would play in both the Shinco and Yahama DVD player! Thanks very much for all your help and also for the booktype tool.

I have been only getting 1.5x burns. I thought this was normal. However, during this process, I think I finally figured out why. growisofs is causing the kernal to turn DMA off on my LG burner. I downloaded cdrtools-2.01.01a10.tar.bz2 and it does not cause the kernel to disable DMA (according to hdparm) and I get 6x DL burn speeds. So I wish to thank Joerg Schilling for cdrecord as well. Note that I must run your booktype tool before running cdrecord in order for my DVD players to read the DVD. I am not sure why growisofs is causing the kernel to turn DMA off. However I read somewhere that the LG burner takes a long time to recognize disk types. Perhaps growisofs is trying to do some kind of verify after writes?

cdrecord does output an interesting message though:

cdrecord: DMA speed too slow (OK for 1x). Cannot write at speed 6x

However then it proceeds to burn as 6x as can be seen below!

Last chance to quit, starting real write    0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
Starting new track at sector: 0
Track 01: 7088 of 7088 MB written (fifo 100%) [buf  97%]   6.1x.
Track 01: Total bytes read/written: 7432421376/7432421376 (3629112 sectors).
Writing  time:  927.259s
Average write speed   5.8x.
Min drive buffer fill was 94%
Fixating time:  195.009s
cdrecord: fifo had 117069 puts and 117069 gets.
cdrecord: fifo was 0 times empty and 29738 times full, min fill was 62%.

Any comments by Joerg Schilling would be appreciated.

~$ dvd+rw-mediainfo /dev/dvd
INQUIRY:                [HL-DT-ST][DVDRAM GSA-4167B][DL12]
L0 Data Zone Capacity: 1440640*2KB, can no longer be set
Disc status:           appendable
Track State:           invisible
Next Writable Address: 2881264*2KB
READ CAPACITY:          0*2048=0

I can mount the disk but my DVD players won't read it.

The disk is simply open it's not mystery that player won't read it. Try http://fy.chalmers.se/~appro/linux/DVD+RW/close.cpp to close the media. But I'd recommend to try to exchange the unit, as it's really abnormal behavior. Talk to your retailer. For reference, close.cpp was written for users who suffered from bug in 5.19, which was leaving media open.

I tried this with the DL12 and the DL13 firmware but it did not work. It was very strange.After I ran the tool, dvd+rw-mediainfo would report that the disk was closed. However, once I ejected the disk and re-loaded, dvd+rw-mediainfo would once again report that the disk was not closed (appendable and incomplete)! I tried this several times but was never able to close this disk with your tool (close.cpp) or cdrecord.

Given that I misinterpreted the original query, there is a way to improve playability of media in question by running 'growisofs -M /dev/cdrom=/dev/zero' to close the disc. It doesn't guarantees playability in the above mentioned affected player though, as it still may have problems to play DVD+R DL media in general. A.

I tried it with the original 6.1 growisofs and the modified one on above disk and got the following:

~$ growisofs -M /dev/dvd=/dev/zero
:-( unable to pread64(2) primary volume descriptor: Input/output error
   you most likely want to use -Z option.

growisofs -M /dev/dvd=/dev/zero pads multi-session media with *closed* tracks till full capacity. In other words I was referring to the media you've recorded without -dvd-compat. Point is that DL media recorded without -dvd-compat can have unrecorded area in second layer, which might confuse player calibrating system and limit playability in legacy units. A.

I tried the above as well with the DL13 firmware. However, I got a write error towards the end of the disk and growisofs would not fixate it (I waited over 10 minutes). Now, my DVD burner will not even recognize the disk ( one more coaster :) ) I am not sure how growisofs determines the end of the disk. I believe that a tracksize arguement is required when trying to do something like this with cdrecord.

So, to summarize the successful+R DL GSA-4167B DL13 DVD burning procedure:

   * mkisofs -dvd-video from cdrtools-2.01.01a10.tar.bz2
   * dvd+rw-booktype -dvd-rom -unit+r /dev/dvd  from
   * Burn the disk
         o Use modified growisofs 6.1 - however slow burn since kernel
           turns DMA off
         o Use cdrecord  -v -dao dev=0,0,0 driveropts=burnfree -data
           from cdrtools-2.01.01a10.tar.bz2. Full speed burn and DMA
           stays enabled.

I do have a question about the dvd+rw-booktype tool. How long do the settings stay active? Do I have to use it before every burn? (I currently do). Is there a similar tool for -R DL disks?

I also would be happing for any suggestions regarding the kernel turning DMA off with growisofs. Again thanks for all your help and best wishes.

Reply to: