[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: LSB wrapper library

On Tue, Apr 03, 2001 at 04:07:29PM +0200, Andreas Jaeger wrote:
> This will not work in a reliable way.
> If you only fork e.g. libc.so.6 and leave the rest you get the problem
> that two dynamic linkers are loaded since all non-forked libs, like
> libreadline in my example below, are linked against ld-linux.so.2.  We
> shouldn't load two different versions of the linker.

Actually, ld-linux.so.2 is only DT_NEEDED by /lib/libc.so.6.  The only
reason it shows up in the trace for libncurses and libtermcap is
because they're linked agsinst glibc and we're running an unmodified
glibc.  So without a "rewrite /lib/ld-linux.so.2 dependency as
/lib/ld-lsb.so.1" hack in ld-lsb.so.1, one would have to make a
compatibility version of glibc that has DT_NEEDED of /lib/ld-lsb.so.1
to fix this problem.



Reply to: