[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [gopher] Dynamically linked Mosaic on Linux??

On 2010-11-07 23:14, Florian E. Teply wrote:

First, i wouldn't want to make a static build for my laptop as RAM is
already scarce in modern terms (only 512 Meg).

[kimmy@x301 ~]$ ldd bin/Mosaic
        linux-vdso.so.1 =>  (0x00007fffde7ff000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0x00007fc72bfbd000)
        libXpm.so.4 => /usr/lib/libXpm.so.4 (0x00007fc72bdac000)
        libXm.so.3 => not found
        libXmu.so.6 => /usr/lib/libXmu.so.6 (0x00007fc72bb91000)
        libXt.so.6 => /usr/lib/libXt.so.6 (0x00007fc72b92d000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0x00007fc72b5f0000)
        libICE.so.6 => /usr/lib/libICE.so.6 (0x00007fc72b3d5000)
        libSM.so.6 => /usr/lib/libSM.so.6 (0x00007fc72b1cd000)
        libc.so.6 => /lib/libc.so.6 (0x00007fc72ae6b000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007fc72ac4f000)
        libdl.so.2 => /lib/libdl.so.2 (0x00007fc72aa4b000)
        libuuid.so.1 => /lib/libuuid.so.1 (0x00007fc72a846000)
        /lib64/ld-linux-x86-64.so.2 (0x00007fc72c1e3000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0x00007fc72a643000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007fc72a43e000)

Not completely static build for me anyway... and it seems that I'm missing libXm :-). What else did you want as libraries?

Looking at the sources, at least these are built statically:

[kimmy@x301 mosaic27ck8]$ ls -d lib*
libdtm  libhtmlw  libnet  libnut  libwww2  libXmx

Also libpng, libjpeg and libgif are strangely integrated into the codebase... I probably wouldn't even try to separate those...

Second, it doesn't work
out-of-the-box either (static linking that is) due to some library

Hmm. Worked for me for my frankendebian system (part testing, part unstable, some experimental and a doze of ubuntu) a few months ago. Looks like it doesn't work now since I'm missing Xm.

[fiddling with stuff]

Just downloaded the latest version from Cameron (mosaic27ck9) and it worked on my system without any patching. Version k8 required some fiddling with readline() to work in Linux but this one worked out of the box.

I have these development packages installed:

[kimmy@x301 mosaic27ck9]$ dpkg --get-selections | grep -- -dev | awk '{ print $1 }' | xargs echo

autotools-dev dpkg-dev libc-dev-bin libc6-dev libice-dev libjpeg62-dev libmotif-dev libncurses5-dev libncursesw5-dev libossp-sa-dev libpng12-dev libpthread-stubs0-dev libsm-dev libstdc++6-4.4-dev libx11-dev libxau-dev libxcb1-dev libxdmcp-dev libxext-dev libxmu-dev libxpm-dev libxt-dev linux-libc-dev manpages-dev x11proto-core-dev x11proto-input-dev x11proto-kb-dev x11proto-print-dev x11proto-xext-dev xtrans-dev xutils-dev zlib1g-dev

That's probably way more than enough though, I've got devs for other software too.

- Kim

Gopher-Project mailing list

Reply to: