[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#595139: apt: multiarch installation chokes on binNMUs

tag 595139 wontfix

2010/9/2 Steve Langasek <vorlon@debian.org>:
> On Thu, Sep 02, 2010 at 02:42:35PM +0200, David Kalnischkies wrote:
>> 2010/9/1 Simon Richter <sjr@debian.org>:
>> > when trying to install a multiarch package that has been binNMUed on one
>> > architecture, apt complains about being unable to resolve the implicit
>> > conflicts, as the version number is not the same across all
>> > architectures.
>> This is really a problem…
>> but not only here but in general as at least changelog.Debian.gz will differ
>> (a bit) and can therefore not be shared between the installed packages.
>> So, i guess it is a bug in the MultiarchSpec [0]. (cc'ing Steve Langasek)
> Sorry, it's not a bug in the spec, but an acknowledged limitation.
> Multi-Arch: same packages *must* be kept in version lockstep across
> architectures, which means that binNMUs will be of reduced value for such
> packages.

Thanks for the explanation Steve Langasek!

The behavior of APT is therefore intended and i add wontfix
in the hope that others might see this bug before reporting it again.
Adding this conflict between multiarch and bin-uploads to the Spec
would be a worthy addition, too, i guess (or is it written somewhere
and i just missed it?)

Best regards

David Kalnischkies

Reply to: