[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#595139: apt: multiarch installation chokes on binNMUs

Hello (again) Simon Richter,

2010/9/1 Simon Richter <sjr@debian.org>:
> when trying to install a multiarch package that has been binNMUed on one
> architecture, apt complains about being unable to resolve the implicit
> conflicts, as the version number is not the same across all
> architectures.

This is really a problem…
but not only here but in general as at least changelog.Debian.gz will differ
(a bit) and can therefore not be shared between the installed packages.
So, i guess it is a bug in the MultiarchSpec [0]. (cc'ing Steve Langasek)

source:Version is a problem as the source version is not always the same
version as the one the binary rebuild is based on - e.g. comerr-dev
(bad example, but the first i found) which would have in a binary rebuild
e.g. version 2.1-1.41.12-2+b1 while source is e2fsprogs (1.41.12-2)…

Best regards

David Kalnischkies

[0] https://wiki.ubuntu.com/MultiarchSpec#Architecture-independent%20files%20in%20multiarch%20packages

Reply to: