[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#503195: apt-get: unable to retrieve linux-image-2.6-amd64 source package



Package: apt
Version: 0.7.16
Severity: normal

Hi there!

It seems that apt-get has some problems retrieving some package sources:
=====
luca@gismo:~/test$ apt-get source linux-image-2.6-amd64
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to find a source package for linux-latest-2.6

luca@gismo:~/test$ apt-get source linux-latest-2.6
Reading package lists... Done
Building dependency tree
Reading state information... Done
Need to get 18.6kB of source archives.
Get:1 http://cdn.debian.net sid/main linux-latest-2.6 16 (dsc) [5007B]
Get:2 http://cdn.debian.net sid/main linux-latest-2.6 16 (tar) [13.6kB]
Fetched 18.6kB in 0s (23.3kB/s)
dpkg-source: extracting linux-latest-2.6 in linux-latest-2.6-16
dpkg-source: info: unpacking linux-latest-2.6_16.tar.gz

luca@gismo:~/test$ apt-cache showsrc linux-image-2.6-amd64
Package: linux-latest-2.6
Binary: [...]
Version: 16
Priority: optional
Section: admin
Maintainer: Debian Kernel Team <debian-kernel@lists.debian.org>
Build-Depends: debhelper (>= 4.1.0), linux-support-2.6.26-1
Architecture: alpha amd64 i386 arm armel hppa ia64 m68k mips mipsel powerpc s390 sparc
Standards-Version: 3.7.3
Format: 1.0
Directory: pool/main/l/linux-latest-2.6
Files:
 dcec335bab9704c1ed7a3aacb5da93b4 5007 linux-latest-2.6_16.dsc
 3580928fd00411c13ed7a8e89b1c2e93 13593 linux-latest-2.6_16.tar.gz
Uploaders: Bastian Blank <waldi@debian.org>, Frederik Schüler <fs@debian.org>
Checksums-Sha1:
 69e40b7eaa0c5b5f417a092e9cf3448a7c182013 13593 linux-latest-2.6_16.tar.gz
Checksums-Sha256:
 e5cb65a83a2bcbe0ab263394e8223b6fc3b96c3dc3b2a8ead08e3451082f3a5e 13593 linux-latest-2.6_16.tar.gz

luca@gismo:~/test$
=====

However, it seems working with -486 and -itanium, but not with
-openvz-amd64 and -vserver-amd64, strange.  I also tried on agricola.d.o
and with `apt-get source linux-image-2.6-iop32x` works as expected.

Thx, bye,
Gismo / Luca

-- Package-specific info:

-- apt-config dump --

APT "";
APT::Architecture "amd64";
APT::Build-Essential "";
APT::Build-Essential:: "build-essential";
APT::Install-Recommends "false";
APT::Install-Suggests "0";
APT::Acquire "";
APT::Acquire::Translation "none";
APT::Authentication "";
APT::Authentication::TrustCDROM "true";
APT::NeverAutoRemove "";
APT::NeverAutoRemove:: "^linux-image.*";
APT::NeverAutoRemove:: "^linux-restricted-modules.*";
APT::Cache-Limit "88388604";
APT::Default-Release "unstable";
Dir "/";
Dir::State "var/lib/apt/";
Dir::State::lists "lists/";
Dir::State::cdroms "cdroms.list";
Dir::State::userstatus "status.user";
Dir::State::status "/var/lib/dpkg/status";
Dir::Cache "var/cache/apt/";
Dir::Cache::archives "archives/";
Dir::Cache::srcpkgcache "srcpkgcache.bin";
Dir::Cache::pkgcache "pkgcache.bin";
Dir::Etc "etc/apt/";
Dir::Etc::sourcelist "sources.list";
Dir::Etc::sourceparts "sources.list.d";
Dir::Etc::vendorlist "vendors.list";
Dir::Etc::vendorparts "vendors.list.d";
Dir::Etc::main "apt.conf";
Dir::Etc::parts "apt.conf.d";
Dir::Etc::preferences "preferences";
Dir::Bin "";
Dir::Bin::methods "/usr/lib/apt/methods";
Dir::Bin::dpkg "/usr/bin/dpkg";
Dir::Log "var/log/apt";
Dir::Log::Terminal "term.log";
DPkg "";
DPkg::Pre-Install-Pkgs "";
DPkg::Pre-Install-Pkgs:: "/usr/sbin/apt-listbugs apt || exit 10";
DPkg::Pre-Install-Pkgs:: "/usr/bin/apt-listchanges --apt || test $? -ne 10";
DPkg::Pre-Install-Pkgs:: "/usr/sbin/dpkg-preconfigure --apt || true";
DPkg::Tools "";
DPkg::Tools::Options "";
DPkg::Tools::Options::/usr/sbin/apt-listbugs "";
DPkg::Tools::Options::/usr/sbin/apt-listbugs::Version "2";
DPkg::Tools::Options::/usr/bin/apt-listchanges "";
DPkg::Tools::Options::/usr/bin/apt-listchanges::Version "2";
Acquire "";
Acquire::PDiffs "false";

-- /etc/apt/preferences --

Package: *
Pin: release a=unstable
Pin-Priority: 990

Package: *
Pin: release a=Unofficial Multimedia Packages
Pin-Priority: 300

-- /etc/apt/sources.list --

# -*- mode: apt-sources -*-
#
# Time-stamp: <2008/09/09 19:58:08 CEST luca@gismo.pca.it>


# Debian.org
# automatic selection through DNS
# http://lists.debian.org/debian-devel/2008/02/msg00216.html
# http://lists.debian.org/debian-devel/2008/02/msg00700.html
# deb http://cdn.debian.net/debian/ testing main contrib non-free
deb http://cdn.debian.net/debian/ sid main non-free contrib
deb http://cdn.debian.net/debian/ experimental main non-free contrib
# deb-src http://cdn.debian.net/debian/ stable main contrib non-free
# deb-src http://cdn.debian.net/debian/ testing main contrib non-free
deb-src http://cdn.debian.net/debian/ sid main contrib non-free
deb-src http://cdn.debian.net/debian/ experimental main contrib non-free

# Debian security updates
#deb http://security.debian.org/ stable/updates main contrib non-free
#deb-src http://security.debian.org/ stable/updates main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb-src http://security.debian.org/ testing/updates main contrib non-free

# http://wiki.debian.org/DebianKernel
deb http://kernel-archive.buildserver.net/debian-kernel sid main
deb http://kernel-archive.buildserver.net/debian-kernel trunk main
deb-src http://kernel-archive.buildserver.net/debian-kernel sid main
deb-src http://kernel-archive.buildserver.net/debian-kernel trunk main

# emacs-snapshot
deb http://emacs.orebokech.com sid main
deb-src http://emacs.orebokech.com sid main

# http://wiki.debian.org/pkg-fso
deb http://pkg-fso.alioth.debian.org/debian unstable main
deb-src http://pkg-fso.alioth.debian.org/debian unstable main

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.26-trunk-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages apt depends on:
ii  debian-archive-keyring   2008.04.16+nmu1 GnuPG archive keys of the Debian a
ii  libc6                    2.7-15          GNU C Library: Shared libraries
ii  libgcc1                  1:4.3.2-1       GCC support library
ii  libstdc++6               4.3.2-1         The GNU Standard C++ Library v3

apt recommends no packages.

Versions of packages apt suggests:
pn  apt-doc                       <none>     (no description available)
pn  aptitude | synaptic | gnome-a <none>     (no description available)
ii  bzip2                         1.0.5-1    high-quality block-sorting file co
ii  dpkg-dev                      1.14.22    Debian package development tools
ii  lzma                          4.43-14    Compression method of 7z format in

-- no debconf information

Attachment: pgpvttxWUVJFO.pgp
Description: PGP signature


Reply to: