[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#167398: selecting packages via depends relations, esp. with versioned deps

On Fri, Nov 01, 2002 at 10:14:43PM -0500, Daniel Burrows wrote:
>   Hi,
>   First, I can reproduce this easily, thanks for a good report.

 Nothing but the best for Debian :)
>   aptitude does not go around manually fulfilling dependencies for
> packages just because a particular version was selected.  I could, but
> that's apt's job!
> As I have said before, I am very disinclined to
> maintain unnecessary hacks and workarounds for deficiencies in apt;
> they should be fixed at the source.

 True enough.  I'm all for cutting out layers of cruft.

>   aptitude will already ask apt (the apt libraries) to automatically
> fulfill dependencies for what you select.  apt is apparently ignoring
> those dependencies because they are not from your default distribution
> (or release, I can't remember the "proper" term)
>   You can check that this behavior is present in the underlying
> libraries by trying to install tubesock with apt-get.

 It's a general problem, not at all specific to tubesock.  It happens any
time I'm installing a package that has dependencies that can't be satisfied
from stable.  I've already got tubesock/unstable installed, so I need to
find another package who's unstable version has unsatisfied deps from
# apt-get install nessus/unstable
Sorry, but the following packages have unmet dependencies:
  nessus: Depends: libnessus1 (>= 1.2.5) but 1.0.10-2 is to be installed
E: Sorry, broken packages

 Try it yourself with any such package.  They're easy to find if you've got
a mostly-stable system.

>   I'm forwarding this to the apt maintainers.  If they say this will
> never be fixed in apt, I might consider hacking around it.

 You can tell apt which release to take as the default on the command line:

root@llama]~# apt-get install nessus -t unstable
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
  libnessus1 libpcap0.7 
The following NEW packages will be installed:
2 packages upgraded, 1 newly installed, 0 to remove and 444  not upgraded.
Need to get 276kB/338kB of archives. After unpacking 180kB will be freed.
Do you want to continue? [Y/n] n

(you don't need to say nessus/unstable, since apt-get install means
"install/upgrade these packages")

 This results in all dependencies being satisfied by installing the unstable
version, even if some of the dependencies would have been happy with the
stable version, so it can result in more packages tracking the unstable
version than necessary.

 You didn't mention the more specific problem of the wrong versions getting
selected in aptitude, but I take it that's what the retitle to something
about MarkInstall was about.  As long as that gets fixed, it won't be too
painful to select the deps, then for any that are still red, go into their
page and select their deps...  There aren't too many recursive trees of deps
that would need to get selected.  Once you've pulled in the unstable version
of e.g. the gnome libs for one package, they're there for any other
gnome-using packages you want to bump up to unstable.  Anyway, as long as
the things I pointed out that are unquestionably bugs get fixed, things will
be acceptable for people that only use aptitude and don't know about 
apt-get -t unstable.

#define X(x,y) x##y
Peter Cordes ;  e-mail: X(peter@llama.nslug. , ns.ca)

"The gods confound the man who first found out how to distinguish the hours!
 Confound him, too, who in this place set up a sundial, to cut and hack
 my day so wretchedly into small pieces!" -- Plautus, 200 BC

Reply to: