[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#122182: Where does xserver-common depend on dialog?



On Mon, Dec 03, 2001 at 04:45:26PM +0100, Adrian Bunk wrote:
> Hi Branden,
> 
> while reassigning this bug you wrote: "xserver-common declares a versioned
> Depends: on the fixed version of dialog." While looking at the
> xserver-common-4.1.0-9 package in unstable I can't see any dependency on
> dialog. Could it be that you fixed the bug in a package you didn't upload
> until now or that the dependency got lost somewhere?

Er, sorry, no, re-reading my own changelog, what I did was add a
versioned dep on debconf (>= 1.0.16), which includes debconf's portion
of the bugfix (see its changelog).

Should this bug be reassigned to debconf?  Should debconf delcare a
versioned dependency or conflict on dialog?  Or should I?

I think this probably should be on debconf's plate.  I'm not sure
xserver-common should care what version of dialog is available, since
that debconf frontend might not even be used.  I would think it's
debconf's job to make sure a broken dialog is not on the system, and
apt's job to make sure any such dependencies are satisfied for package
pre-configuration.

Please let me know if my reasoning is flawed.  I don't know exactly what
magic apt performs to ensure that dependencies are met for
pre-configuration.

-- 
G. Branden Robinson                |    I must despise the world which does
Debian GNU/Linux                   |    not know that music is a higher
branden@debian.org                 |    revelation than all wisdom and
http://people.debian.org/~branden/ |    philosophy. -- Ludwig van Beethoven

Attachment: pgp0h231Mu5Qm.pgp
Description: PGP signature


Reply to: