[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#87767: apt-get upgrade fails strangely (Depends: libapt-pkg2.7)

Jason Gunthorpe wrote:

> On Mon, 26 Feb 2001, Peter S Galbraith wrote:
> > Should this be severity important?  It doesn't work for me at all...
> How is this even a bug!?
> You upgraded apt, which removed the libapt-pkg2.7, so those programs have
> issues now.
> Jason

Ah, sorry.  I just noticed that apt 0.3.19 provides
libapt-pkg2.7.  Didn't think of that.  I just upgraded apt to try
it, saw no message about libapt-pkg2.7 when installing, and just
assumed any subsequent error was with apt, not normal packaging.

I'm surprised that dpkg let me upgrade apt when that clearly
breaks already installed apt-move et el. that depend on
libapt-pkg2.7.  I didn't have to force install.

Reply to: