[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#57335: apt: bashism in dselect methods script

Package: apt
Version: 0.3.17
Severity: normal


The file /usr/lib/dpkg/methods/apt/install declares itself to be
a #!/bin/sh interpreted script, yet uses syntactical forms not
supported by the Bourne Shell standard.

The culprit is on line 67 of the file:

  if [ "x$OLDLS" == "x$NEWLS" ]; then

Please change the above line into:

  if [ "x$OLDLS" = "x$NEWLS" ]; then



-- System Information
Debian Release: 2.2
Kernel Version: Linux pc47 2.2.13 #1 Thu Oct 21 01:06:08 CEST 1999 i686 unknown

Versions of the packages apt depends on:
ii  libc6          2.1.3-1        GNU C Library: Shared libraries and Timezone
ii  libstdc++2.10  2.95.2-5       The GNU stdc++ library

Reply to: